Bug 1299678 - Nova support for Intel Cache Allocation Technology
Nova support for Intel Cache Allocation Technology
Status: CLOSED DUPLICATE of bug 1411864
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Eoghan Glynn
nlevinki
: FutureFeature, Triaged
Depends On: 1289368 1288964
Blocks: 1412215
  Show dependency treegraph
 
Reported: 2016-01-18 19:36 EST by Karen Noel
Modified: 2017-07-25 10:31 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1289368
Environment:
Last Closed: 2017-07-25 10:31:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karen Noel 2016-01-18 19:36:40 EST
+++ This bug was initially created as a clone of Bug #1289368 +++

Kernel support for CAT requires libvirt support:

Bug 1288964 - [Intel 7.3 FEAT] Enable Cache Allocation Technology (CAT)
Comment 2 Sahid Ferdjaoui 2016-01-19 10:58:48 EST
A spec will have to be addressed, after a first look this feature needs some work in several components of Nova to maintain/schedule/consume host's cache. I can work on that spec and implementation it when libvirt will provides information about cache and feature to use it for guests.
Comment 5 Kashyap Chamarthy 2017-01-06 10:03:02 EST
After having a quick chat with the Real Time folks Rik van Riel, and 
Luiz Capitulino, A quick summary of current status.  There are a couple
of things at play here.

 - Kernel. The Kernel infrastructure is ready and merged upstream.  And
   there's work in-progress to get these patches into RHEL
 
 - Integration into virtualization stack -- libvirt to provide an API.

 - Once libvirt provides the API to configure cache reservation, then it
   can be exposed in OpenStack Nova.


About the feature itself:
https://software.intel.com/en-us/articles/introduction-to-cache-allocation-technology
Comment 6 Stephen Gordon 2017-07-25 10:31:23 EDT

*** This bug has been marked as a duplicate of bug 1411864 ***

Note You need to log in before you can comment on or make changes to this bug.