Bug 1299701 - Can't upgrade native-ha environment by atomic-openshift-installer
Can't upgrade native-ha environment by atomic-openshift-installer
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 23:01 EST by Anping Li
Modified: 2016-02-29 07:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 07:57:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2016-01-18 23:01:31 EST
Description of problem:
I failed to upgrade native-ha environment by atomic-openshift-installer. get message "openshift_master_cluster_method must be set to 'pacemaker'". As I know, only native-ha can be installed by atomic-openshift-installer. so atomic-openshift-installer upgrade should support "None HA master" and "Native HA masters". Pacemaker should be the forbidden one.


Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.35

How reproducible:
always

Steps to Reproduce:
1. install native-ha master ose-3.1.0.4 by atomic-openshift-installer
2. upgrade to ose-3.1.1.x by atomic-openshift-installer upgrade
   atomic-openshift-installer upgrade



Actual results:
PLAY [Evaluate additional groups for upgrade] ********************************* 

GATHERING FACTS *************************************************************** 
ok: [localhost]

TASK: [Evaluate etcd_hosts_to_backup] ***************************************** 
ok: [localhost] => (item=ose31master1.example.com)
ok: [localhost] => (item=ose31master2.example.com)
ok: [localhost] => (item=ose31master3.example.com)

PLAY [Verify upgrade can proceed] ********************************************* 

TASK: [fail ] ***************************************************************** 
failed: [ose31master1.example.com] => {"failed": true}
msg: openshift_master_cluster_method must be set to 'pacemaker'

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/upgrade.retry

localhost                  : ok=10   changed=0    unreachable=0    failed=0   
ose31master.example.com    : ok=7    changed=0    unreachable=0    failed=0   
ose31master1.example.com   : ok=7    changed=0    unreachable=0    failed=1   
ose31master2.example.com   : ok=7    changed=0    unreachable=0    failed=0   
ose31master3.example.com   : ok=7    changed=0    unreachable=0    failed=0   
ose31node1.example.com     : ok=7    changed=0    unreachable=0    failed=0   
ose31node2.example.com     : ok=7    changed=0    unreachable=0    failed=0   

Expected results:
atomic-openshift-installer can upgrade native ha environment

Additional info:
Comment 1 Brenton Leanhardt 2016-01-19 08:42:05 EST
Today 'atomic-openshift-installer upgrade' only support upgrading from 3.0.z to 3.1.z.  It doesn't handle minor upgrades.  We know that is confusing however, the documentation we will ship for 3.1.1 will provide instructions on running the 3.1 to 3.1.1 upgrade directly with ansible.  We plan in the near future to have 'atomic-openshift-installer upgrade' allow you to select (or detect) the upgrade you would like to perform.
Comment 2 Anping Li 2016-02-15 03:58:27 EST
nativeha envirnoment can be updated with atomic-openshift-utils-3.0.40-1.git.22.da21865.el7aos.noarch now. the bug  status can be move on.
Comment 4 Anping Li 2016-02-16 23:56:48 EST
Verified and pass
Comment 6 errata-xmlrpc 2016-02-29 07:57:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0311

Note You need to log in before you can comment on or make changes to this bug.