Bug 129973 - /usr/lib/anaconda/iw/network_gui.py:265 syntax error when installing
/usr/lib/anaconda/iw/network_gui.py:265 syntax error when installing
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-08-15 22:51 EDT by Camille Zavala
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-22 15:53:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Camille Zavala 2004-08-15 22:51:49 EDT
Description of problem:
After showing the Boot Loader Configuration page, a dialog box 
entitled "Exception Occured" (hmm, it should be "Occurred") with the 

File "/usr/lib/anaconda/gui.py", line 775, in nextClicked
File "/usr/lib/anaconda/gui.py", line 1086, in setScreen
  exec s
File "<string>", line 1, in ?
File "/usr/lib/anaconda/iw/network_gui.py", line 265

SyntaxError: invalid syntax

Version-Release number of selected component (if applicable):

Fedora 3 Test 1, CD 1

How reproducible:

Install on Toshiba 7020CT notebook (366 MHZ, 192 Mb memory, in DVD 

Steps to Reproduce:
1. Boot CD 1 => Graphical install => Skip media test => Workstation
2. Auto-partition the disk => Remove all partitions, not just Linux
3. Review partitions => (look at them) => click Next button
4. Bootloader Config page appears and the installer poots
Actual results:

Error dialog box as noted above

Expected results:

Continue with the installation

Additional info:

Toshiba 7020CT, 366 MHZ, 192 (max) Mb memory, 6 Gb hard drive, DVD 
dock with Intel E100 network NIC chip.  No PCMCIA used.
Comment 1 Camille Zavala 2004-08-15 23:10:14 EDT
*D'oh!*  I forgot to mention that it's a Toshiba _Portege_ 7020CT 
with a Pentium II chip.

I verified the CDs when I burned them (with the Mac OS X/Panther Disk 
Utility), and did the Media Test on the first CD.  Both tests passed.

On the second attempt I tried:
* Remove all Linux partitions (not all partitions like last time)
* No review of partitions created

It worked!  I got past the Boot Loader Configuration screen through 
to the Network Configuration screen.  So that's a (possible) 
Comment 2 Camille Zavala 2004-08-16 03:37:11 EDT
reassigning it from the incorrect "test3" to the correct "test1".
Comment 3 Jeremy Katz 2004-08-16 13:28:46 EDT
That traceback looks suspiciously like a CD read problem.  Could you
attach the full dump?
Comment 4 Camille Zavala 2004-08-17 01:10:27 EDT
Shucks, that traceback was the whole error message.

Is there somewhere else I can fetch a dump from, now that I've
installed FC3t1?  I did a "find /var -type f | xargs egrep
/usr/lib/anaconda/iw/network_gui.py" but it didn't find anything.

Hardware note:  It was reading the CD in the DVD reader in the dock,
but you've already figured that out.

And you caught that typo about Occurred having two r's in the dialog
box's title bar, right?  I can submit a separate bug report if it's
absolutely necessary.

Note You need to log in before you can comment on or make changes to this bug.