Bug 1299742 - Fail to install containerized environment with non-root user
Fail to install containerized environment with non-root user
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Andrew Butcher
Ma xiaoqiang
:
: 1312768 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 02:37 EST by Ma xiaoqiang
Modified: 2016-07-03 20:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 07:57:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2016-01-19 02:37:15 EST
Description of problem:
Fail to install containerized environment with non-root user

Version-Release number of selected component (if applicable):
openshift-ansible-3.0.35-1.git.0.6a386dd.el7aos.noarch

How reproducible:
always

Steps to Reproduce:
1. Install contaierized environment on rhel7 or atomic with non-root user
<--snip-->
ansible_ssh_user=install
deployment_type=openshift-enterprise
ansible_sudo=true
containerized=true
<--snip-->

Actual results:
TASK: [openshift_master | Create the policy file if it does not already exist] *** 
failed: [openshift-138.lab.eng.nay.redhat.com] => {"cmd": "oadm create-bootstrap-policy-file --filename=/etc/origin/master/policy.json", "failed": true, "rc": 2}
msg: [Errno 2] No such file or directory

FATAL: all hosts have already failed -- aborting


Expected results:
Install environment successfully.

Additional info:
Comment 1 Brenton Leanhardt 2016-01-20 08:20:42 EST
For QE,

Would you mind testing this using master from https://github.com/openshift/openshift-ansible ?

You can use the same Ansible inventory generated by atomic-openshift-installer but instead of having it start the ansible run simply run it manually and point it to the byo config playbook.
Comment 4 Ma xiaoqiang 2016-01-21 19:49:42 EST
yeah, the master branch works fine.
Comment 5 Brenton Leanhardt 2016-01-22 08:56:17 EST
Great.  We'll include this in an upcoming ASYNC advisory once we get 3.1.1 out the door.
Comment 7 errata-xmlrpc 2016-02-29 07:57:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0311
Comment 8 Gaoyun Pei 2016-03-03 22:23:25 EST
*** Bug 1312768 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.