Bug 1299789 - [RFE] Error for Non Existing attribute while adding Matcher.
Summary: [RFE] Error for Non Existing attribute while adding Matcher.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Smart Variables
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1278718
TreeView+ depends on / blocked
 
Reported: 2016-01-19 09:38 UTC by Jitendra Yejare
Modified: 2018-07-17 18:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-17 18:56:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 13271 0 None None None 2016-04-22 14:56:24 UTC

Description Jitendra Yejare 2016-01-19 09:38:24 UTC
Description of problem:
Currently If we are trying to add matcher for 'non existing attribute' in Smart Class Parameter/Smart Variables it raises as error 'Match <attribute_name> =  <value> does not match an existing <attribute_name> ' and this is only applicable when attributes are FQDN/HostGroup. It seems this doesn't work / not added for other attributes such as OS, domain etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a matcher for non existing attribute(other than FQDN, HostGroup) for smart class parameter / variable other.
2. Attempt to submit.

Actual results:
No Error raised for Attribute not existing in satellite.

Expected results:
Error should be raised for non existence of attribute and for all the attributes.

Additional info:

Comment 3 Ivan Necas 2016-04-26 12:34:02 UTC
I believe this is done by design, to be able to specify the matcher even for cases where the data are not yet available, but we expect them to appear in the system later (when facts are uploaded from hosts). We can change the RFE to warn (but not prevent) from saving the smart variables, in which case we would not even had distinguish between fqdn/hostgroup and something else. Anyway, proposing for 6.3 as it's not something we would commit for 6.2

Comment 4 Bryan Kearney 2016-07-08 20:41:11 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 6 Bryan Kearney 2016-08-10 19:12:58 UTC
Upstream bug component is Configuration Management

Comment 7 Bryan Kearney 2016-08-10 20:13:57 UTC
Upstream bug component is Provisioning

Comment 8 Bryan Kearney 2016-08-10 22:13:36 UTC
Upstream bug component is Configuration Management

Comment 9 Bryan Kearney 2016-08-12 12:51:22 UTC
Upstream bug component is Smart Variables

Comment 10 Bryan Kearney 2018-07-17 18:56:52 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.