Bug 1299790 - texlive-stix and stix-fonts conflicts
texlive-stix and stix-fonts conflicts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 04:39 EST by Mattias Ellert
Modified: 2016-01-22 16:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 16:16:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2016-01-19 04:39:39 EST
Description of problem:

Updating to the latest texlive in rawhide fails due to texlive-stix trying to overwrite /usr/share/fonts/stix already installed by stix-fonts.

Version-Release number of selected component (if applicable):

texlive-stix-svn36914.1.1.2-19.fc24
stix-fonts-1.1.0-8.fc23

How reproducible:

Always

Actual results:

Update fails due to conflict

Expected results:

Update should succeed

Additional info:

If texlive-stix is supposed to replace stix-fonts (which is reasonable), there should be proper Obsoletes/Provides defined in texlive-stix so that updating does the replacement.

The texlive-stix package is also missing the font(stix) provides and the requires on fontpackages-filesystem. Please implement the font packaging guidelines properly for all texlive subpackages that install fonts in /usr/share/fonts.
Comment 1 Tom "spot" Callaway 2016-01-22 16:16:32 EST
Latest texlive in rawhide resolves this.

Note You need to log in before you can comment on or make changes to this bug.