Bug 129980 - menu method creates ~/.config/menus/*.menu files
menu method creates ~/.config/menus/*.menu files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-16 03:45 EDT by Mark McLoughlin
Modified: 2013-03-05 22:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 08:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2004-08-16 03:45:29 EDT
While playing around with overriding the default menu layout
using $XDG_CONFIG_DIRS I realized it wasn't working because
we're generating these files which merge in the system wide
layout.

Clearly, we shouldn't be generating these files at all.
Comment 1 Dan Williams 2004-09-12 11:07:47 EDT
Hmm?  I thought that's how menu editing should be working, the local
user could override the system layout...  When you modify a menu, a
local .menu file is created which merges in the system menus, but then
has a delete/exclude of certain items...  I'm not quite sure what you
mean here by "shouldn't be generating these files at all".  Do you
mean we shouldn't be generating the local-user .menu files?  If not,
how would the local user modify the menus on a per-user basis (if we
want that, which I thought we did)?
Comment 2 Mark McLoughlin 2004-09-13 05:38:50 EDT
Sorry, should have explained better - this is without any menu editing.

Create test user, log in, you've got the files. That's what doesn't
make sense. This could well be the pleasecreate patch in gnome-vfs2,
moving to there.
Comment 3 Mark McLoughlin 2005-04-07 08:04:49 EDT
Doesn't happen with gnome-menus in rawhide

Note You need to log in before you can comment on or make changes to this bug.