Bug 1299809 - CPU Right Size recommendations only take into account CPU sockets, not cores per socket
CPU Right Size recommendations only take into account CPU sockets, not cores ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity high
: GA
: 5.7.0
Assigned To: Adam Grare
Dmitry Misharov
c&u
: TestOnly, ZStream
: 1323326 (view as bug list)
Depends On:
Blocks: 1348631
  Show dependency treegraph
 
Reported: 2016-01-19 05:09 EST by Peter McGowan
Modified: 2017-01-11 23:48 EST (History)
12 users (show)

See Also:
Fixed In Version: 5.7.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1348631 (view as bug list)
Environment:
Last Closed: 2017-01-11 15:02:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Right sizing screenshot (149.57 KB, image/png)
2016-04-20 02:16 EDT, Dmitry Misharov
no flags Details
Correct amount of CPUs (122.12 KB, image/png)
2016-09-09 09:55 EDT, Dmitry Misharov
no flags Details

  None (edit)
Description Peter McGowan 2016-01-19 05:09:45 EST
Description of problem:
If a VMware VM has 1 socket, with multiple cores per socket, then the right-size recommendations for that VM only seem to show the VM as having 1 CPU.

Version-Release number of selected component (if applicable):
CFME 5.5.0.13
vCenter 5.5

How reproducible:
Every Time

Steps to Reproduce:
1. Create a VMware VM with 4 CPUs, configured as 1 socket x 4 cores.
2. Allow the VM to run long enough to gather C&U data
3. Access the Right Size Recommendations for this VM.

Actual results:
The Right Size Recommendations show the VM as having 1 CPU, and therefore calculations are incorrect

Expected results:
The Right Size Recommendations show the VM as having 4 CPUs

Additional info:
Comment 5 CFME Bot 2016-01-27 15:02:35 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/b06a35f1342839a7a266f2aa8ad56290c86fde69

commit b06a35f1342839a7a266f2aa8ad56290c86fde69
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Mon Jan 25 11:01:59 2016 -0500
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Mon Jan 25 20:06:55 2016 -0500

    Use cpu_total_cores for vm cpu right_size
    
    CPU right size recommendation was reporting a VM with 1 socket
    and 4 cores as having 1 total CPU.  Use cpu_total_cores instead
    of num_cpu to correctly report the total number of logical CPUs.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299809

 app/models/vm_or_template/right_sizing.rb | 6 +++---
 spec/factories/hardware.rb                | 6 ++++++
 spec/models/metric_spec.rb                | 2 +-
 3 files changed, 10 insertions(+), 4 deletions(-)
Comment 6 Colin Arnott 2016-04-06 12:11:32 EDT
*** Bug 1323326 has been marked as a duplicate of this bug. ***
Comment 7 Dmitry Misharov 2016-04-20 02:16:09 EDT
Right sizing recommendation still shows 1 CPU for 4 core machine in 5.6.0.1-beta2.20160413141124_e25ac0e . Look at the attached screenshot.
Comment 8 Dmitry Misharov 2016-04-20 02:16 EDT
Created attachment 1148870 [details]
Right sizing screenshot
Comment 12 CFME Bot 2016-08-09 15:25:42 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/694733a8c0fc99d7e2f8b9e4710e90ae4a7ead5e

commit 694733a8c0fc99d7e2f8b9e4710e90ae4a7ead5e
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Mon Aug 8 16:31:46 2016 -0400
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Mon Aug 8 16:31:46 2016 -0400

    Display total cpu cores for right sizing
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299809

 app/views/vm_common/_right_size.html.haml | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
Comment 16 David La Motta 2016-08-28 07:26:47 EDT
The hotfix is showing recommendation, savings and savings % in terms of cores. However, the UI and right-sizing reports display headers and labels as CPUs. This is very misleading and should be addressed--most probable in another BZ.

On the reports we at least have the option to rename the headers, but on the UI as in attachment 1194407 [details] we are stuck at looking at labels that indicate CPUs and not cores.
Comment 19 Dmitry Misharov 2016-09-09 09:55 EDT
Created attachment 1199471 [details]
Correct amount of CPUs

Fixed and verified in 5.7.0.0.20160906172503_12f65cb. Right Size recommendations shows correct amount of cpus.

Note You need to log in before you can comment on or make changes to this bug.