Bug 1299812 - crm_node output changed which breaks some openstack-foreman-installer scripts
crm_node output changed which breaks some openstack-foreman-installer scripts
Status: CLOSED DUPLICATE of bug 1290684
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pacemaker (Show other bugs)
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Ken Gaillot
Depends On:
  Show dependency treegraph
Reported: 2016-01-19 05:24 EST by GE Scott Knauss
Modified: 2016-02-16 21:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-20 03:56:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description GE Scott Knauss 2016-01-19 05:24:08 EST
Description of problem:

most recent version of pacemaker (1.1.13-10.el7) changes the output of crm_node which is breaking scripts in openstack foreman installer.

Version-Release number of selected component (if applicable):


How reproducible:

attempt to deploy openstack using foreman installer after updating to latest pacemaker

Actual results:

deployment fails 

Expected results:

successful deployment

Additional info:

Earlier version 1.1.12-22.el7.1.4
[root@controller-1 ~]# /usr/sbin/crm_node -l
2 pcmk-controller-3
3 pcmk-controller-2
1 pcmk-controller-1

With new 1.1.13-10.el7
[root@controller-1 ~]# /usr/sbin/crm_node -l
2 pcmk-controller-3 member
3 pcmk-controller-2 member
1 pcmk-controller-1 member

I.e. there is a third field added which will confuse script

[root@controller-1 ~]# grep crm_node /tmp/ha-all-in-one-util.bash 
  /usr/sbin/crm_node -n
  members=$(/usr/sbin/crm_node -l | perl -p -e 's/^.*\s+(\S+)$/$1/g')
[root@controller-1 ~]# 

making it not get the cluster members but just "member" three times.

This script comes from 

# rpm -qf /usr/share/openstack-foreman-installer/puppet/modules/quickstack/templates/ha-all-in-one-util.erb
Comment 4 GE Scott Knauss 2016-01-19 11:46:51 EST


BZ: 1299987

Comment 5 GE Scott Knauss 2016-01-20 03:56:09 EST

*** This bug has been marked as a duplicate of bug 1290684 ***
Comment 7 Andrew Beekhof 2016-02-16 21:16:20 EST
Right. The mistake is mine. 

I assumed that people would be looking for the second field (and thus it would be safe to add a third).  It didn't occur to me that people would be looking for the 'last' field.

It appears I was/am in the minority.  Sorry.

Note You need to log in before you can comment on or make changes to this bug.