Bug 1299815 - 'Kickstart insufficient' on Installation Destination when installing from iso
'Kickstart insufficient' on Installation Destination when installing from iso
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: ISO Installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Jason Montleon
Tasos Papaioannou
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 05:28 EST by Antonin Pagac
Modified: 2016-09-13 12:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:24:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2016-01-19 05:28:49 EST
Description of problem:
After I start installing from ISO, an Installation Summary screen shows, and there is an error under the Installation Destination:

'Kickstart Insufficient'

and an orange triangle is displayed.

The disk, according to the installer, has 465.76 GiB. There was previous installation of OSP node present on the disk, but I was able to delete it within the installer.

After I tried to run the installer with manual partitioning done by me, a few seconds later there is an error:

"IOException: Partition(s) 2 on /dev/sda have been written, but we have been unable to inform the kernal og the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes."

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20160118.t.0-RHCI-x86_64-dvd1.iso
RHCIOOO-7-RHEL-7-20160118.t.2-RHCIOOO-x86_64-dvd1.iso

How reproducible:
Hit this on both install isos

Steps to Reproduce:
1. Use the machines as a OSP nodes in an RHELOSP deployment
2. Connect the ISO to the machine, restart
3. Boot from the installation ISO and start the installation

Actual results:
Kickstart insufficient and then IOException when storage configured manually

Expected results:
No error; partitions created by kickstart; install continues and finishes successfully

Additional info:
Comment 1 Antonin Pagac 2016-01-19 05:35:01 EST
Workaround is to create the partitioning manually, start the installation, hit the error, restart the machine and run the ISO again. It then works as it should.

When I just restarted the machine and ran the ISO again, the same problem appeared.
Comment 2 Jason Montleon 2016-01-19 10:50:20 EST
The installer does a clearpart; not sure why it's not wiping the disk as I regularly reuse my system without issue. Can you try to reproduce this and provide the anaconda logs?
Comment 3 Jason Montleon 2016-01-19 10:58:27 EST
I just started the installation on a host that was previously an OSP node, it's currently installing RHCI.
Comment 4 John Matthews 2016-01-22 10:27:46 EST
Will investigate further during GA.
Comment 9 Tasos Papaioannou 2016-08-26 15:16:06 EDT
Unable to reproduce the issue. Marking as verified.

Tested on QCIOOO-8.0-RHEL-7-20160823.t.0 + QCI-1.0-RHEL-7-20160825.t.0.
Comment 11 errata-xmlrpc 2016-09-13 12:24:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.