Bug 1299820 - Unable to install ceph epel7 ppc64le on RHEL7.2
Unable to install ceph epel7 ppc64le on RHEL7.2
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ceph (Show other bugs)
epel7
ppc64le Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Boris Ranto
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7ppc64le
  Show dependency treegraph
 
Reported: 2016-01-19 05:39 EST by Menanteau Guy
Modified: 2016-05-10 10:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: ceph-0.80.7-0.8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 10:44:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Menanteau Guy 2016-01-19 05:39:41 EST
On a RHEL7.2 ppc64le where epel7 is installed, I needed ceph as dependency.
When I tried to install ceph-0.80.7-0.7.el7 I've got following errors:

yum install ceph
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package ceph.ppc64le 1:0.80.7-0.7.el7 will be installed
--> Processing Dependency: python-rbd = 1:0.80.7 for package: 1:ceph-0.80.7-0.7.el7.ppc64le
--> Processing Dependency: python-rados = 1:0.80.7 for package: 1:ceph-0.80.7-0.7.el7.ppc64le
--> Processing Dependency: python-cephfs = 1:0.80.7 for package: 1:ceph-0.80.7-0.7.el7.ppc64le
--> Processing Dependency: ceph-common = 1:0.80.7 for package: 1:ceph-0.80.7-0.7.el7.ppc64le
--> Running transaction check
---> Package ceph.ppc64le 1:0.80.7-0.7.el7 will be installed
--> Processing Dependency: python-rbd = 1:0.80.7 for package: 1:ceph-0.80.7-0.7.el7.ppc64le
--> Processing Dependency: python-rados = 1:0.80.7 for package: 1:ceph-0.80.7-0.7.el7.ppc64le
---> Package ceph-common.ppc64le 1:0.80.7-0.7.el7 will be installed
--> Processing Dependency: python-rbd = 1:0.80.7 for package: 1:ceph-common-0.80.7-0.7.el7.ppc64le
--> Processing Dependency: python-rados = 1:0.80.7 for package: 1:ceph-common-0.80.7-0.7.el7.ppc64le
---> Package python-cephfs.ppc64le 1:0.80.7-0.7.el7 will be installed
--> Processing Dependency: python-rados = 1:0.80.7 for package: 1:python-cephfs-0.80.7-0.7.el7.ppc64le
--> Finished Dependency Resolution
Error: Package: 1:ceph-0.80.7-0.7.el7.ppc64le (repo_epel_pc64le)
           Requires: python-rbd = 1:0.80.7
Error: Package: 1:ceph-0.80.7-0.7.el7.ppc64le (repo_epel_pc64le)
           Requires: python-rados = 1:0.80.7
Error: Package: 1:python-cephfs-0.80.7-0.7.el7.ppc64le (repo_epel_pc64le)
           Requires: python-rados = 1:0.80.7
Error: Package: 1:ceph-common-0.80.7-0.7.el7.ppc64le (repo_epel_pc64le)
           Requires: python-rbd = 1:0.80.7
Error: Package: 1:ceph-common-0.80.7-0.7.el7.ppc64le (repo_epel_pc64le)
           Requires: python-rados = 1:0.80.7
 You could try using --skip-broken to work around the problem
 
It seems some packages needed as "Requires" in ceph.spec are no more created.
Comment 2 Fedora Update System 2016-02-23 19:38:08 EST
ceph-0.80.7-0.8.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-589c62bd86
Comment 3 Fedora Update System 2016-02-25 08:20:56 EST
ceph-0.80.7-0.8.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-589c62bd86
Comment 4 Fedora Update System 2016-05-10 10:44:24 EDT
ceph-0.80.7-0.8.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.