Bug 1299823 - F5 router cannot running
F5 router cannot running
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing (Show other bugs)
3.1.0
All All
high Severity high
: ---
: ---
Assigned To: Troy Dawson
zhaozhanqi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 05:47 EST by zhaozhanqi
Modified: 2016-01-29 15:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 15:58:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Ram Ranganathan 2016-01-19 14:22:12 EST
@zhaozhanqi / @brenton that looks like a packaging issue. 
The docker image should contain a symlink that points the /usr/bin/openshift binary -- here's the relevant lines from 
the Dockerfile for images/origin  
 ADD bin/openshift /usr/bin/openshift
 RUN ln -s /usr/bin/openshift /usr/bin/oc && \
     ln -s /usr/bin/openshift /usr/bin/oadm && \
     ... 
     ln -s /usr/bin/openshift /usr/bin/openshift-f5-router && \


And the dockerfile for the F5 router has just 2 lines:
FROM openshift/origin
ENTRYPOINT ["/usr/bin/openshift-f5-router"]

deriving from the openshift/origin image.


You could check the file contents by doing a :
docker export $containerId > foo.tar
tar -tvf foo.tar
Comment 5 zhaozhanqi 2016-01-20 05:04:31 EST
My env meet some error, I will verify this issue once the env is rollback. sorry for that.
Comment 6 Brenton Leanhardt 2016-01-20 08:39:20 EST
I think we should leave this bug ON_QA since is at least ready for QE to test (when your environment is rolled back).
Comment 7 zhaozhanqi 2016-01-22 03:04:34 EST
verified this bug with openshift3/ose-f5-router:latest image id 2cc63b4efbe1

registry.qe.openshift.com/openshift3/ose-f5-router               latest              2cc63b4efbe1        2 days ago          440.3 MB

Note You need to log in before you can comment on or make changes to this bug.