Bug 1299852 - os-apply-config needs to pull python-six
os-apply-config needs to pull python-six
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-apply-config (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Mike Burns
Ola Pavlenko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 07:09 EST by Attila Fazekas
Modified: 2016-04-07 17:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: os-apply-config-0.1.32-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:46:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 260287 None None None 2016-01-19 07:38 EST

  None (edit)
Description Attila Fazekas 2016-01-19 07:09:27 EST
Description of problem:
$ os-apply-config 
Traceback (most recent call last):
  File "/usr/bin/os-apply-config", line 6, in <module>
    from os_apply_config.apply_config import main
  File "/usr/lib/python2.7/site-packages/os_apply_config/apply_config.py", line 29, in <module>
    from os_apply_config import oac_file
  File "/usr/lib/python2.7/site-packages/os_apply_config/oac_file.py", line 19, in <module>
    import tox
ImportError: No module named six


Version-Release number of selected component (if applicable):
0.1.32-3.el7ost

How reproducible:


Steps to Reproduce:
1. yum remove python-tox
2. yum install os-apply-config
3. os-apply-config

Actual results:
Dependency is missing


Expected results:
os-apply-config pulls python-six
Comment 2 Mike Burns 2016-01-19 07:23:47 EST
This is really a very low severity.  python-six is such a base dependency that removing it removes about 50 other packages that are critical.  

That said, it's a trivial fix, so I'll knock it out now.
Comment 4 Ola Pavlenko 2016-03-14 08:25:49 EDT
os-apply-config-0.1.32-4.el7ost.noarch
python-six-1.9.0-2.el7.noarch
Comment 6 errata-xmlrpc 2016-04-07 17:46:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.