Bug 1299879 - check_vol_slaves() in dracut-functions.sh does not strip whitespaces from volume group name
check_vol_slaves() in dracut-functions.sh does not strip whitespaces from vol...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.2
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: dracut-maint
Release Test Team
:
Depends On:
Blocks: 1203710 1289485 1313485
  Show dependency treegraph
 
Reported: 2016-01-19 08:09 EST by Pekka Wallendahl
Modified: 2016-11-04 04:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:02:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2158411 None None None 2016-02-11 07:30 EST

  None (edit)
Description Pekka Wallendahl 2016-01-19 08:09:32 EST
Description of problem:
When I run dracut --debug I get following:
//usr/lib/dracut/dracut-functions.sh@688(check_vol_slaves): lvm lvs --noheadings -o vg_name /dev/mapper/os-root
/usr/lib/dracut/dracut-functions.sh@688(check_vol_slaves): _vg='  os  '
//usr/lib/dracut/dracut-functions.sh@690(check_vol_slaves): printf '%s\n' '  os  '
/usr/lib/dracut/dracut-functions.sh@690(check_vol_slaves): _vg='  os  '
/usr/lib/dracut/dracut-functions.sh@691(check_vol_slaves): [[ -n   os   ]]
//usr/lib/dracut/dracut-functions.sh@684(check_vol_slaves): lvm vgs --noheadings -o pv_name '  os  '
/usr/lib/dracut/dracut-functions.sh@699(check_vol_slaves): return 1

So there're whitespaces that cause check_vol_slaves() to fail.


Version-Release number of selected component (if applicable):
dracut-033-360.el7_2.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have LVM with a volume group named as "os" and have the root LV on that vg
2. run `dracut /tmp/dracut-test.img --debug`
3.

Actual results:
Dracut fails to query the volume group because of escaped whitespaces

Expected results:
Whitespaces should be striped off before attempting to run vgs

Additional info:
This bug has been solved in upstream with commit: https://github.com/haraldh/dracut/commit/2fd8588da51a0e43684852dcdabe327aca684a9f
Comment 4 Mike McCune 2016-03-28 18:31:02 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Michal Kovarik 2016-08-03 07:21:49 EDT
Reproduced on RHEL-7.2 with dracut-033-359.el7. Verified with dracut-033-450.el7. Patch is included, no whitespaces in 'lvm vgs --noheadings -o pv_name rhel_vg'.
Comment 8 errata-xmlrpc 2016-11-04 04:02:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2530.html

Note You need to log in before you can comment on or make changes to this bug.