Bug 1299881 - Missing image causes confusing 'server show' response
Missing image causes confusing 'server show' response
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: ---
: 6.0 (Juno)
Assigned To: Jakub Ruzicka
Avi Avraham
: ZStream
Depends On: 1285429
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 08:15 EST by Ondrej
Modified: 2016-06-08 08:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-openstackclient-1.0.1-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285429
Environment:
Last Closed: 2016-06-08 08:10:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1489901 None None None 2016-01-19 08:15 EST

  None (edit)
Comment 4 Jakub Ruzicka 2016-05-12 10:58:21 EDT
Fix backported.
Comment 6 Avi Avraham 2016-06-06 09:38:11 EDT
The bug was verified the following steps ware done 
1) Verify rpm is installed:
   [root@rhso6rhel7liron ~(keystone_admin)]# rpm -q python-openstackclient
python-openstackclient-1.0.1-3.el7ost.noarch
2) upload an image 
[root@rhso6rhel7liron ~(keystone_admin)]# openstack image create --disk-format qcow2 --container-format bare --public True --file ./cirros-0.3.4-x86_64-disk.img 
+------------------+--------------------------------------+
| Field            | Value                                |
+------------------+--------------------------------------+
| checksum         | ee1eca47dc88f4879d8a229cc70a07c6     |
| container_format | bare                                 |
| created_at       | 2016-06-06T13:01:27                  |
| deleted          | False                                |
| deleted_at       | None                                 |
| disk_format      | qcow2                                |
| id               | 0c56e239-8afe-4179-b5b4-1a13d2cda2b6 |
| is_public        | True                                 |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | True                                 |
| owner            | 8c6181a03a0f41e99defb269ee435b12     |
| properties       | {}                                   |
| protected        | False                                |
| size             | 13287936                             |
| status           | active                               |
| updated_at       | 2016-06-06T13:01:29                  |
| virtual_size     | None                                 |
+------------------+--------------------------------------+

3) server create 
[root@rhso6rhel7liron ~(keystone_admin)]# openstack image create --disk-format qcow2 --container-format bare --public True --file ./cirros-0.3.4-x86_64-disk.img 
+------------------+--------------------------------------+
| Field            | Value                                |
+------------------+--------------------------------------+
| checksum         | ee1eca47dc88f4879d8a229cc70a07c6     |
| container_format | bare                                 |
| created_at       | 2016-06-06T13:01:27                  |
| deleted          | False                                |
| deleted_at       | None                                 |
| disk_format      | qcow2                                |
| id               | 0c56e239-8afe-4179-b5b4-1a13d2cda2b6 |
| is_public        | True                                 |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | True                                 |
| owner            | 8c6181a03a0f41e99defb269ee435b12     |
| properties       | {}                                   |
| protected        | False                                |
| size             | 13287936                             |
| status           | active                               |
| updated_at       | 2016-06-06T13:01:29                  |
| virtual_size     | None                                 |
+------------------+--------------------------------------+
4) server list 
[root@rhso6rhel7liron nova(keystone_admin)]# openstack server list 
+--------------------------------------+-----------+--------+---------------------+
| ID                                   | Name      | Status | Networks            |
+--------------------------------------+-----------+--------+---------------------+
| 771541ac-51f6-4dd6-9d6f-2ad1d10861b0 | test11111 | ACTIVE | public=172.24.4.229 |
| 47def916-de50-44c2-9470-f680ad237dee | test1     | ACTIVE | public=172.24.4.228 |
+--------------------------------------+-----------+--------+---------------------+
5) image delete : 
openstack image delete 0c56e239-8afe-4179-b5b4-1a13d2cda2b6

6) server show image details successfully after delete :
[root@rhso6rhel7liron nova(keystone_admin)]# openstack server show 771541ac-51f6-4dd6-9d6f-2ad1d10861b0
+--------------------------------------+----------------------------------------------------------+
| Field                                | Value                                                    |
+--------------------------------------+----------------------------------------------------------+
| OS-DCF:diskConfig                    | MANUAL                                                   |
| OS-EXT-AZ:availability_zone          | nova                                                     |
| OS-EXT-SRV-ATTR:host                 | rhso6rhel7liron.localdomain                              |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | rhso6rhel7liron.localdomain                              |
| OS-EXT-SRV-ATTR:instance_name        | instance-00000004                                        |
| OS-EXT-STS:power_state               | 1                                                        |
| OS-EXT-STS:task_state                | None                                                     |
| OS-EXT-STS:vm_state                  | active                                                   |
| OS-SRV-USG:launched_at               | 2016-06-06T13:16:55.000000                               |
| OS-SRV-USG:terminated_at             | None                                                     |
| accessIPv4                           |                                                          |
| accessIPv6                           |                                                          |
| addresses                            | public=172.24.4.229                                      |
| config_drive                         |                                                          |
| created                              | 2016-06-06T13:16:16Z                                     |
| flavor                               | m1.small (2)                                             |
| hostId                               | a8587269ef83220d915b131f6ff630742a32df37bff92dc2e36c582e |
| id                                   | 771541ac-51f6-4dd6-9d6f-2ad1d10861b0                     |
| image                                | cirros-avi (0c56e239-8afe-4179-b5b4-1a13d2cda2b6)        |
| key_name                             | None                                                     |
| name                                 | test11111                                                |
| os-extended-volumes:volumes_attached | []                                                       |
| progress                             | 0                                                        |
| properties                           |                                                          |
| security_groups                      | [{u'name': u'default'}]                                  |
| status                               | ACTIVE                                                   |
| tenant_id                            | 8c6181a03a0f41e99defb269ee435b12                         |
| updated                              | 2016-06-06T13:16:55Z                                     |
| user_id                              | dd3f410ddf584d3d940c4116ea651d59                         |
+--------------------------------------+----------------------------------------------------------+
Comment 8 errata-xmlrpc 2016-06-08 08:10:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1211

Note You need to log in before you can comment on or make changes to this bug.