Bug 1299888 - [RFE] Ability to work with an already deployed Directory node from a prior deployment: Empty error displayed after clicking Deploy on Installation Review page
[RFE] Ability to work with an already deployed Directory node from a prior de...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: cchase
Tasos Papaioannou
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 08:33 EST by Antonin Pagac
Modified: 2016-09-13 12:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:24:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first time, rhev+cfme (119.61 KB, image/png)
2016-01-19 08:34 EST, Antonin Pagac
no flags Details
second time, different iso install, osp deployment (93.50 KB, image/png)
2016-01-19 08:36 EST, Antonin Pagac
no flags Details

  None (edit)
Description Antonin Pagac 2016-01-19 08:33:13 EST
Description of problem:
See screenshot. This might be happening due to conflicting tasks, as I have failed a number of deployments before this one and something might be left running.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20160118.t.0-RHCI-x86_64-dvd1.iso
RHCIOOO-7-RHEL-7-20160118.t.2-RHCIOOO-x86_64-dvd1.iso

How reproducible:
Happened to me two distinct times

Steps to Reproduce:
1. Unsure, will fill-in later
2.
3.

Actual results:
Empty error displayed; deployment can't continue

Expected results:
Error with informative text displayed

Additional info:
Comment 1 Antonin Pagac 2016-01-19 08:34 EST
Created attachment 1116175 [details]
first time, rhev+cfme
Comment 2 Antonin Pagac 2016-01-19 08:36 EST
Created attachment 1116176 [details]
second time, different iso install, osp deployment
Comment 3 Antonin Pagac 2016-01-19 09:37:53 EST
I have reproduced this by running freshly installed RHCI and using Director from previous installs with already discovered and assigned nodes. After hitting deploy, the error appears. There is no error in production.log.
Comment 4 cchase 2016-01-25 09:36:42 EST
Addressed empty error messages in https://github.com/fusor/fusor/pull/649
Comment 5 Jason Montleon 2016-04-27 11:21:32 EDT
Have you undeployed the old undercloud deployment? OSP director only supports one deployment.
Comment 6 Todd Sanders 2016-04-27 11:47:54 EDT
I'd suggest that we add a check as part of our undercloud validation (when users enters IP + credentials) whereby we add to the existing validation the following:

1. Does the undercloud provided have an existing deployment?

2> If so, prompt the user and ask if they want to undeploy and reuse the existing under cloud.

Would this satisfy the RFE request?
Comment 7 Todd Sanders 2016-04-27 11:48:10 EDT
I'd suggest that we add a check as part of our undercloud validation (when users enters IP + credentials) whereby we add to the existing validation the following:

1. Does the undercloud provided have an existing deployment?

2> If so, prompt the user and ask if they want to undeploy and reuse the existing under cloud.

Would this satisfy the RFE request?
Comment 8 Antonin Pagac 2016-04-28 07:26:16 EDT
(In reply to Jason Montleon from comment #5)
> Have you undeployed the old undercloud deployment? OSP director only
> supports one deployment.

If I haven't undeployed the Overcloud, there would be an error after hitting the deploy button and syncing content, and it would say 'The Stack (overcloud) already exists'. This is relevant: bug 1289058


(In reply to Todd Sanders from comment #7)
> I'd suggest that we add a check as part of our undercloud validation (when
> users enters IP + credentials) whereby we add to the existing validation the
> following:
> 
> 1. Does the undercloud provided have an existing deployment?
> 
> 2> If so, prompt the user and ask if they want to undeploy and reuse the
> existing under cloud.
> 
> Would this satisfy the RFE request?

I think this is exactly what we need. Similar solution was proposed by Jason in upper mentioned bug 1289058 comment 1.
Comment 9 Jason Montleon 2016-05-17 17:10:36 EDT
https://github.com/fusor/egon/pull/69 was created and merged to support this.
Comment 10 cchase 2016-05-20 17:58:23 EDT
https://github.com/fusor/fusor/pull/876

Modified the undercloud deploy page to detect if there was an already deployed overcloud and halt progress with an error alert.

Added the ability to delete an overcloud from the undercloud-deploy page.

Prevent deployment if trying to deploy to an undercloud with a deployed overcloud.
Comment 15 Tasos Papaioannou 2016-08-25 13:24:48 EDT
Verified on QCI-1.0-RHEL-7-20160824.t.1 + QCIOOO-8.0-RHEL-7-20160823.t.0. If I use the same undercloud in a new QCI deployment, and the heat stack still exists on the undercloud, I am given the option to delete the stack or to detect a new undercloud before I can continue.
Comment 17 errata-xmlrpc 2016-09-13 12:24:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.