Bug 1299889 - apache user is not created during httpd installation when apache group already exist
apache user is not created during httpd installation when apache group alread...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd (Show other bugs)
7.2
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Web Stack Team
Martin Frodl
: ZStream
Depends On:
Blocks: 1319001
  Show dependency treegraph
 
Reported: 2016-01-19 08:33 EST by Roman Bobek
Modified: 2016-11-04 04:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: httpd-2.4.6-41
Doc Type: Bug Fix
Doc Text:
The httpd package installation script tried to create both the "apache" user and group in a single "useradd" command. Consequently, when the "apache" group had already been created on the system, the command failed, and the "apache" user was not created. To fix this bug, the "apache" group is now created by a separate command, and the "apache" user is correctly created during httpd installation even when the "apache" group exists.
Story Points: ---
Clone Of:
: 1319001 1486843 (view as bug list)
Environment:
Last Closed: 2016-11-04 04:10:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2201021 None None None 2016-03-16 10:00 EDT

  None (edit)
Description Roman Bobek 2016-01-19 08:33:17 EST
Description of problem:

When installing httpd via yum and apache group already exists on the system (for example when it is defined in IDM), installation is not able to create apache user:

warning: user apache does not exist - using root


Problem is caused by way the new user is created:

/usr/sbin/useradd -c "Apache" -u 48 \
        -s /sbin/nologin -r -d /usr/share/httpd apache 2> /dev/null || :

This causes httpd unable to start.


Version-Release number of selected component (if applicable):
RHEL 7.2
httpd 2.4


How reproducible:
By creating group apache and than trying to install httpd.


Steps to Reproduce:
1. groupadd apache --gid=48
2. yum install httpd


Actual results:
Error message: warning: user apache does not exist - using root
httpd unable to start

Expected results:
Smooth installation of httpd. httpd is able to start.


Additional info:
We found this issue thanks to enclosed support case. The problem here was, that customer had apache group defined in IDM.
Comment 14 errata-xmlrpc 2016-11-04 04:10:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2534.html

Note You need to log in before you can comment on or make changes to this bug.