This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1299909 - gnocchi-upgrade does not work in current RDO trunk
gnocchi-upgrade does not work in current RDO trunk
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tooz (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 9.0 (Mitaka)
Assigned To: Pradeep Kilambi
Yurii Prokulevych
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 09:17 EST by Emilien Macchi
Modified: 2016-08-11 08:13 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-tooz-1.34.0-1.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 08:13:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emilien Macchi 2016-01-19 09:17:35 EST
Description of problem:
When deploying Gnocchi on RDO trunk, gnocchi-upgrade does not work.

List / version of packages:
http://logs.openstack.org/14/269214/2/check/gate-puppet-gnocchi-puppet-beaker-rspec-dsvm-centos7/e02fd01/logs/rpm-qa.txt.gz

How reproducible:
Deploy RDO trunk using delorean and install Gnocchi.
Run gnocchi-upgrade to sync gnocchi database.

Actual results:
http://logs.openstack.org/14/269214/2/check/gate-puppet-gnocchi-puppet-beaker-rspec-dsvm-centos7/e02fd01/console.html#_2016-01-18_18_55_42_986

Expected results:
Feed Gnocchi database without error.

Additional info:
Look https://github.com/alecthomas/voluptuous/commit/80c9f2c4b4205ea8f0417f17066b0b8e172f9516

It seems we would need to update voluptuous to 0.8.6 or 0.8.8?
Comment 1 Julien Danjou 2016-01-19 09:33:32 EST
Gnocchi does need voluptuous 0.8.6 at least. Fixing upstream too. Should be included in Gnocchi 1.3.4.
Comment 2 Julien Danjou 2016-01-19 09:36:01 EST
Argh, this is a problem in tooz dependency, not Gnocchi actually. I misread the log.
Comment 3 Pradeep Kilambi 2016-01-20 12:33:09 EST
fix submitted to  upstream packaging:

https://review.gerrithub.io/#/c/260456/
Comment 5 Pradeep Kilambi 2016-07-28 13:32:20 EDT
I think this has been resolved for quite sometime now. Moving to Modified.
Comment 7 Yurii Prokulevych 2016-08-08 10:27:37 EDT
Verified with downstream packages:

rpm -qR python-tooz-1.34.0-1.el7ost.noarch | grep vol
python-voluptuous >= 0.8.6

rpm -qR python-gnocchi-2.1.3-2.el7ost.noarch | grep vol
python-voluptuous

Command with dedicated empty db executed successfully:

gnocchi-upgrade --verbose --debug --create-legacy-resource-types --config-file /etc/gnocchi/gnocchi.conf
Comment 9 errata-xmlrpc 2016-08-11 08:13:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html

Note You need to log in before you can comment on or make changes to this bug.