Bug 1299916 - nova is configured to talk to keystone via localhost and keystone listens only to public IP
nova is configured to talk to keystone via localhost and keystone listens onl...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
All Linux
medium Severity medium
: ---
: 10.0 (Newton)
Assigned To: Angus Thomas
Omri Hochman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 09:38 EST by Michele Baldessari
Modified: 2016-10-25 04:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 09:37:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michele Baldessari 2016-01-19 09:38:33 EST
Description of problem:
I am running the latest poodle as of today on a virthost deployment.
The issue is that keystone is configured to listen to the public IP only:
netstat -tapen|grep LISTEN |grep 35357
tcp        0      0 192.0.2.1:35357         0.0.0.0:*               LISTEN      163        163744     6869/python2 

And nova is configured to talk to keystone via localhost:
nova/nova.conf:admin_url=http://127.0.0.1:35357/v2.0

Version-Release number of selected component (if applicable):
Repos:
rhelosp-8.0-director-ceph-1.3-mon   
rhelosp-8.0-director-ceph-1.3-osd   
rhelosp-8.0-director-poodle/x86_64  
rhelosp-8.0-poodle/x86_64           
rhelosp-8.0-unittest                
rhelosp-rhel-7-common/x86_64        
rhelosp-rhel-7-extras/x86_64        
rhelosp-rhel-7-ha/x86_64            
rhelosp-rhel-7-server/x86_64        
rhelosp-rhel-7-z/x86_64             
rhos-release                        
rhos-release-extras/7Server         


Packages:

[root@instack etc]# rpm -qa | grep "openstack-puppet-modules\|tripleo\|instack"
openstack-tripleo-heat-templates-0.8.7-2.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-2.el7ost.noarch
instack-undercloud-2.2.1-2.el7ost.noarch
openstack-tripleo-0.0.7-1.el7ost.noarch
openstack-tripleo-common-0.0.2-5.el7ost.noarch
instack-0.0.8-2.el7ost.noarch
openstack-puppet-modules-7.0.3-1.el7ost.noarch
python-tripleoclient-0.0.11-6.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy via khaleesi and latest poodle aka
http://ayanami.bos.devel.redhat.com/poodles/rhos-devel-ci/8.0-director/2016-01-19.1/RHOS-8-director/$basearch/os/

It might be that the issue is in some nova puppet module and not in instack-undercloud. I am not too familiar with all the components so feel free to reassign if this is a puppet-module issue or something else
Comment 2 Mike Burns 2016-04-07 17:03:37 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Sven Anderson 2016-10-14 09:22:43 EDT
This has been reported in January... This barely can be an issue until now, a lot of things changed since then. Michele, do you agree?
Comment 6 Sven Anderson 2016-10-14 09:37:05 EDT
After chat with reporter on IRC this will be closed.

Note You need to log in before you can comment on or make changes to this bug.