Bug 1299963 - [RFE] Reporting: Unable to report on CF Tenant Quotas
[RFE] Reporting: Unable to report on CF Tenant Quotas
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Libor Pichler
Jiri Stefanisin
tenant_cfme:report
: FutureFeature, ZStream
Depends On:
Blocks: 1318717
  Show dependency treegraph
 
Reported: 2016-01-19 10:52 EST by Kevin Morey
Modified: 2016-06-29 11:31 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.2
Doc Type: Enhancement
Doc Text:
There was a feature request to add an ability to report on CloudForms tenant quotas. This was because an administrator or user of a tenant would like to report on what each tenant is consuming in a widget or in the case of a self-service user how much quota they are currently using. With this enhancement, such reporting is now available.
Story Points: ---
Clone Of:
: 1318717 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:31:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Morey 2016-01-19 10:52:48 EST
Description of problem:
With the introduction of cfme 5.5.x we now have the ability to assign tenant quotas. This is great!  However, as an administrator or even a user of a tenant I would like to see/report on what each tenant is consuming in a widget or in the case of a self-service user how much quota they are currently using. This is just one of the scenarios that we desperately need to be able to show during a POC. Please escalate this.

Version-Release number of selected component (if applicable):
5.5.2.1

How reproducible:
100%

Steps to Reproduce:
1. Navigate to Cloud Intelligence / Reports (as an admin)
2. Attempt to create a report that shows what each tenant is consuming on a per group or user basis.
3. 

Actual results:
You can't do this.

Expected results:
Expected to be able to build reports and widgets based on tenant quota.  Inf fact as i am researching this the it seems that tenants are missing in the reporting relationships for all CI's.

Additional info:
Comment 7 errata-xmlrpc 2016-06-29 11:31:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.