Bug 1299968 - Rebase libqb to 1.0 for RHEL7.3
Rebase libqb to 1.0 for RHEL7.3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libqb (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Christine Caulfield
cluster-qe@redhat.com
: Rebase
: 1308505 (view as bug list)
Depends On:
Blocks: 1313485 1296673 1302087 1348726
  Show dependency treegraph
 
Reported: 2016-01-19 10:59 EST by Christine Caulfield
Modified: 2016-11-04 00:40 EDT (History)
8 users (show)

See Also:
Fixed In Version: libqb-1.0-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:40:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2016-01-19 10:59:20 EST
libqb 1.0 contains several small fixes and also the split-logging facility needed for later versions of pacemaker.
Comment 2 Chris Feist 2016-02-22 15:07:08 EST
*** Bug 1308505 has been marked as a duplicate of this bug. ***
Comment 5 Sam McLeod 2016-05-22 21:49:47 EDT
Fantastic - looking forward to this, the current version of libqb in 7.2 is causing us major issues with crashing Corosync and taking nodes offline etc...

Sorry for my ignorance but is there a place to get the new libqb-1.0-1.el7 version of the package in advance of it's release so that I may test it - I can't see it in fasttrack etc...?
Comment 6 Sam McLeod 2016-05-23 02:03:25 EDT
I don't think I can add a related bug in BugZilla here, but this libqb upgrade will also apparently fix: https://bugzilla.redhat.com/show_bug.cgi?id=1114852#c64
Comment 7 Christine Caulfield 2016-05-23 02:54:19 EDT
Sam, there's no externally visible RHEL7.3 version of libqb yet, but there is a Fedora version and, of course, the source code is on github.
Comment 8 Sam McLeod 2016-05-23 03:41:55 EDT
Thanks Christine, no worries, I've built my own package for RHEL / CentOS 7.2 from source.

I've uploaded the built packages (including the SRPM) in case anyone else wants them for any reason: https://packagecloud.io/app/mrmondo/pacemaker/search?q=libqb
Comment 9 Sam McLeod 2016-05-30 21:39:12 EDT
FYI - after upgrading to libqb-1.0 on our 7.2 servers we have no longer experienced the problems with corosync crashing that were causing us major issues.
Comment 10 Christine Caulfield 2016-06-06 03:24:43 EDT
Thanks for the feedback!
Comment 11 Jan Pokorný 2016-06-06 17:53:12 EDT
Sam, FYI, if you followed the right channels, you would be aware of
COPR builds I keep updated on regular basis (shortly after new release):

http://oss.clusterlabs.org/pipermail/users/2016-April/002658.html
Comment 12 Jan Pokorný 2016-06-17 11:28:48 EDT
Might be worthy new respin:
https://github.com/ClusterLabs/libqb/issues/215
Comment 13 Sam McLeod 2016-06-18 06:29:04 EDT
(In reply to Jan Pokorný from comment #12)
> Might be worthy new respin:
> https://github.com/ClusterLabs/libqb/issues/215

I agree, the blackbox component of Pacemaker is very useful when debugging issues, I would consider this a medium severity regression if this was to be broken.
Comment 14 Christine Caulfield 2016-06-20 03:17:11 EDT
That issue isn't a regression, it's an unimplemented feature. In fact it only came up because a recent patch to pacemaker used the %z modifier. As I understand it that Pacemaker patch will be removed anyway so that earlier libqb versions can be supported. 

I'll put this patch into libqb, of course, but it has no impact on existing code so it will go out in the next minor release.
Comment 15 Ken Gaillot 2016-06-20 20:15:45 EDT
Pacemaker has been updated not to use %z as of commit 380c1bb, which will be part of the 1.1.15 release. No Pacemaker release, whether upstream or in RHEL, will have a problem with older versions of corosync.
Comment 18 errata-xmlrpc 2016-11-04 00:40:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2363.html

Note You need to log in before you can comment on or make changes to this bug.