Bug 1299987 - crm_node output changed which breaks some openstack-foreman-installer scripts
crm_node output changed which breaks some openstack-foreman-installer scripts
Status: CLOSED DUPLICATE of bug 1290684
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
6.0 (Juno)
x86_64 Linux
urgent Severity urgent
: ---
: 8.0 (Liberty)
Assigned To: Jason Guiditta
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 11:44 EST by GE Scott Knauss
Modified: 2016-04-18 02:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 12:31:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GE Scott Knauss 2016-01-19 11:44:53 EST
Description of problem:

most recent version of pacemaker (1.1.13-10.el7) changes the output of crm_node which is breaking scripts in openstack foreman installer.

Version-Release number of selected component (if applicable):

1.1.13-10.el7

How reproducible:

attempt to deploy openstack using foreman installer after updating to latest pacemaker



Actual results:

deployment fails 

Expected results:

successful deployment

Additional info:

Earlier version 1.1.12-22.el7.1.4
[root@controller-1 ~]# /usr/sbin/crm_node -l
2 pcmk-controller-3
3 pcmk-controller-2
1 pcmk-controller-1

With new 1.1.13-10.el7
[root@controller-1 ~]# /usr/sbin/crm_node -l
2 pcmk-controller-3 member
3 pcmk-controller-2 member
1 pcmk-controller-1 member

I.e. there is a third field added which will confuse script

[root@controller-1 ~]# grep crm_node /tmp/ha-all-in-one-util.bash 
  /usr/sbin/crm_node -n
  members=$(/usr/sbin/crm_node -l | perl -p -e 's/^.*\s+(\S+)$/$1/g')
[root@controller-1 ~]# 

making it not get the cluster members but just "member" three times.

This script comes from 

# rpm -qf /usr/share/openstack-foreman-installer/puppet/modules/quickstack/templates/ha-all-in-one-util.erb
openstack-foreman-installer-3.0.26-1.el7ost.noarch
Comment 2 Jason Guiditta 2016-01-19 12:31:00 EST
Please reopen if you feel this is a different problem

*** This bug has been marked as a duplicate of bug 1290684 ***

Note You need to log in before you can comment on or make changes to this bug.