Bug 1299991 - Change dependency from gpg to gpg2
Change dependency from gpg to gpg2
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: parcimonie.sh (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Till Hofmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 12:07 EST by Christian Stadelmann
Modified: 2016-01-20 02:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 02:15:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2016-01-19 12:07:18 EST
Description of problem:
According to its README.md file [1] parcimonie.sh is "tested with GnuPG 2, probably works OK with 1.* as well".
The spec file currently "Requires: gnupg" to be installed, which is GnuPG 1.4.x.
Since parcimonie.sh is designed for GnuPG 2 I suggest changing the package dependency to "Requires: gnupg2". 

[1] https://github.com/EtiennePerot/parcimonie.sh/blob/master/README.md

Version-Release number of selected component (if applicable):
0-0.4.20150804gitc009937.fc23

How reproducible:
always – packaging

Additional info:
This change will also require a patch for parcimonie.sh due to different gnupg binary names:

$ diff old/parcimonie.sh new/parcimonie.sh
14c14
< gnupgBinary="${GNUPG_BINARY:-gpg}"
---
> gnupgBinary="${GNUPG_BINARY:-gpg2}"
Comment 1 Till Hofmann 2016-01-20 02:15:13 EST
There is currently a bug (due to major changes to gnupg) in parcimonie.sh which breaks parcimonie.sh with any gnupg >= 2.1.4 [1]. Thus, gnupg2 cannot be used on Fedora. Since gnupg 1.4 is supported too, we will stick with gnupg 1.4 until the bug is resolved.



[1] https://github.com/EtiennePerot/parcimonie.sh/issues/15

Note You need to log in before you can comment on or make changes to this bug.