Bug 1300007 - start-statd: don't run multiple rpc.statds on the one host.
Summary: start-statd: don't run multiple rpc.statds on the one host.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
: 1224357 (view as bug list)
Depends On:
Blocks: 1313485 1295577 1390487
TreeView+ depends on / blocked
 
Reported: 2016-01-19 18:00 UTC by Steve Dickson
Modified: 2016-11-04 05:03 UTC (History)
5 users (show)

Fixed In Version: nfs-utils-1.3.0-0.30.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1390487 (view as bug list)
Environment:
Last Closed: 2016-11-04 05:03:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description Steve Dickson 2016-01-19 18:00:26 UTC
Description of problem:

I've seen a number of reports of multiple rpc.statds being started..

Description of problem:
commit d92017cccaffb02f7f4e00d0fdd6ef5042bb6341
Author: NeilBrown <neilb@suse.com>
Date:   Sat Jan 16 12:09:50 2016 -0500

    start-statd: don't run multiple rpc.statds on the one host.
    
    If rpc.statd is running but slow to respond, mount.nfs will
    run "start-statd" which might start a new statd.  This is not a good
    ideas as can result in lots of rpc.statds.
    
    So inf start-statd check the pid file and if rpc.statd seems to be
    running, exit with success.
    
    (also "cd /" before running rpc.statd, just in case).
    
    Signed-off-by: NeilBrown <neilb@suse.com>
    Signed-off-by: Steve Dickson <steved@redhat.com>

Comment 6 Steve Dickson 2016-04-26 14:51:51 UTC
*** Bug 1224357 has been marked as a duplicate of this bug. ***

Comment 10 Steve Dickson 2016-06-20 17:40:11 UTC
The upstream commit...
   http://marc.info/?l=linux-nfs&m=146644251031055&w=2

Comment 11 Steve Dickson 2016-06-21 16:16:50 UTC
commit 8fef90084f3d19e90ba1bb22b8cd1d58ddaf6ef3
Author: Steve Dickson <steved@redhat.com>
Date:   Tue Jun 21 12:06:06 2016 -0400

    start-statd: Use flock to serialize the running of this script

Comment 13 Yongcheng Yang 2016-07-05 07:34:16 UTC
Move to VERIFIED as test logs in comment 12.
Continue to run the automatic case.

Comment 15 errata-xmlrpc 2016-11-04 05:03:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.