Bug 1300010 - virt-builder fails periodically with: libguestfs error: could not connect to libvirt (URI = qemu:///session): Cannot write data: Transport endpoint is not connected
virt-builder fails periodically with: libguestfs error: could not connect to ...
Status: CLOSED DUPLICATE of bug 1271183
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 13:20 EST by Ryan Sawhill
Modified: 2016-01-19 16:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 14:02:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libguestfs-test-tool output (57.12 KB, text/plain)
2016-01-19 13:20 EST, Ryan Sawhill
no flags Details
virt-builder -v -x output (6.98 KB, text/plain)
2016-01-19 13:21 EST, Ryan Sawhill
no flags Details

  None (edit)
Description Ryan Sawhill 2016-01-19 13:20:03 EST
Created attachment 1116298 [details]
libguestfs-test-tool output

Description of problem:

  Periodically virt-builder fails with the following error when running as non-root users:

  virt-builder: error: libguestfs error: could not connect to libvirt (URI = qemu:///session): Cannot write data: Transport endpoint is not connected [code=38 domain=7]

Version-Release number of selected component (if applicable):

  I'm using the latest version in F23, which at the moment is 1.32.0-1.fc23. One of my colleagues sees the exact same issue in RHEL7 w/ 1.28.1-1.55.el7.

How reproducible:

  It happens regularly when using virt-builder as non-root users -- nothing fancy ... just --hostname, --run-command, --firstboot; however, it never happens twice in a row -- i.e., if I run the exact same virt-builder cmd right after the error, it always succeeds the second time.

Additional info:

  See attached files for `libguestfs-test-tool` and `virt-builder -v -x` output.
Comment 1 Ryan Sawhill 2016-01-19 13:21 EST
Created attachment 1116299 [details]
virt-builder -v -x output
Comment 2 Richard W.M. Jones 2016-01-19 14:02:23 EST
Fixed if you build libvirt-1.3.1-1.fc24 which is now
in dist-git (but not yet built in Rawhide).

http://koji.fedoraproject.org/koji/packageinfo?packageID=91

*** This bug has been marked as a duplicate of bug 1271183 ***
Comment 3 Ryan Sawhill 2016-01-19 16:42:13 EST
Hmmm. Thanks for the heads-up rwmj. After reading that I better understand the problem. I can work-around it in my app that calls virt-builder. Cheers.
Comment 4 Richard W.M. Jones 2016-01-19 16:50:39 EST
You shouldn't need to work around anything.  Is there a reason
not to use the fixed libvirt and/or patch libvirt with the
fixes?

You'll also find this thread useful:
https://www.redhat.com/archives/libvir-list/2016-January/thread.html#00502

Note You need to log in before you can comment on or make changes to this bug.