Bug 1300013 - openstack-aodh now requires python-gnocchiclient
openstack-aodh now requires python-gnocchiclient
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: distribution (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: trunk
Assigned To: Pradeep Kilambi
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 13:34 EST by David Moreau Simard
Modified: 2016-04-18 02:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-gnocchiclient-2.1.0-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 18:59:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace (deleted)
2016-01-19 13:34 EST, David Moreau Simard
no flags Details

  None (edit)
Description David Moreau Simard 2016-01-19 13:34:40 EST
Since yesterday, openstack-aodh requires python-gnocchiclient:
https://github.com/openstack/aodh/commit/fa3a982a27d698333ac213cbe8faac5ba2a56079

If gnocchiclient is not installed, the db-sync for aodh (probably amongst other things) will fail - see attached stacktrace.

I meant to add python-gnocchiclient>=2.1.0 as a Requires in the aodh spec file but noticed we only had python-gnocchiclient 2.0 in http://buildlogs.centos.org/centos/7/cloud/openstack-liberty/.

Either we need to bump the version of gnocchiclient in the deps repo or we create a mitaka deps repo with an updated version ?
Comment 1 Alan Pevec 2016-01-21 15:10:01 EST
python-gnocchiclient-2.1.0-1.el7 is in delorean deps repo
Comment 2 David Moreau Simard 2016-01-21 15:52:47 EST
Submitted fix for added dependency https://review.gerrithub.io/#/c/260572/

Note You need to log in before you can comment on or make changes to this bug.