Bug 130004 - 2.6.8-1.520 kernel NFS client OOPs
2.6.8-1.520 kernel NFS client OOPs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-16 11:40 EDT by H.J. Lu
Modified: 2015-01-04 17:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 13:04:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages as a user with NFS-mounted home logs in (3.57 KB, text/plain)
2004-09-07 06:46 EDT, Bevis King
no flags Details

  None (edit)
Description H.J. Lu 2004-08-16 11:40:02 EDT
Unable to handle kernel NULL pointer dereference at virtual address
00000014
 printing eip:
41b9fabd
*pde = 00003001
Oops: 0002 [#1]
SMP
Modules linked in: nfs nfsd exportfs lockd md5 ipv6 parport_pc lp
parport autofs4 sunrpc e1000 floppy sg microcode dm_mod joydev
uhci_hcd ehci_hcd button battery asus_acpi ac ext3 jbd ata_piix libata
sd_mod scsi_mod
CPU:    1
EIP:    0060:[<41b9fabd>]    Not tainted
EFLAGS: 00010246   (2.6.8-1.520.hjl.0smp)
EIP is at nfs3_request_init+0xb/0x14 [nfs]
eax: 00000000   ebx: 3fdce800   ecx: 3af2c90c   edx: 3ae91880
esi: 03710be0   edi: 3fdce800   ebp: 40c0c600   esp: 3fe57ae0
ds: 007b   es: 007b   ss: 0068
Process zsh (pid: 2924, threadinfo=3fe57000 task=3acaabb0)
Stack: 3fdce800 41b9903c 3af2c90c 3ae91880 3af2c90c 00000006 03710be0
00001000
       41b9b4f3 00000000 00001000 0213c044 03710be0 3fe57b98 03710be0
3fe57c44
       00000000 41b9b49f 0214273f 3af2c9bc 00000000 00000000 000001f4
00001487
Call Trace:
 [<41b9903c>] nfs_create_request+0xd4/0xdd [nfs]
 [<41b9b4f3>] readpage_async_filler+0x54/0xfc [nfs]
 [<0213c044>] add_to_page_cache+0x5a/0xe1
 [<41b9b49f>] readpage_async_filler+0x0/0xfc [nfs]
 [<0214273f>] read_cache_pages+0x6e/0xd3
 [<41b9b60a>] nfs_readpages+0x6f/0x91 [nfs]
 [<021427d1>] read_pages+0x2d/0xd0
 [<0213ff05>] buffered_rmqueue+0x1bf/0x1e7
 [<0213ffd1>] __alloc_pages+0xa4/0x285
 [<02142c83>] do_page_cache_readahead+0x1d1/0x1f1
 [<02142dd4>] page_cache_readahead+0x131/0x19e
 [<0213c8a4>] do_generic_mapping_read+0xbe/0x355
 [<0213cdd8>] __generic_file_aio_read+0x1a5/0x1c3
 [<0213cb3b>] file_read_actor+0x0/0xf8
 [<0213ce36>] generic_file_aio_read+0x40/0x47
 [<41b9516a>] nfs_file_read+0xc1/0xcb [nfs]
 [<0215aa93>] do_sync_read+0x6a/0x99
 [<02158177>] rw_vm+0x2f7/0x349
 [<0215ab78>] vfs_read+0xb6/0xe2
 [<02164c3b>] kernel_read+0x31/0x3b
 [<021658f4>] prepare_binprm+0xc3/0xcc
 [<02165dcc>] do_execve+0x13d/0x239
 [<02104a88>] sys_execve+0x2a/0x70
Code: f0 ff 40 14 89 43 18 5b c3 56 31 f6 53 89 c3 8b 40 0c 39 d0
Comment 1 Bevis King 2004-09-07 06:43:05 EDT
I am seeing this same fault with the -520 kernel on FC3test1. 
Enclosed below is my messages log relating to it.
Comment 2 Bevis King 2004-09-07 06:46:10 EDT
Created attachment 103536 [details]
/var/log/messages as a user with NFS-mounted home logs in

This shows the Oops as a user with an NFS mounted home logs in.  Server is an
RH7.3 box operating as NFSv3/UDP.
Comment 3 Bevis King 2004-09-07 09:27:53 EDT
This seems to be an upstream bug, and the linux-2.6.8.1 subrelease is
basically a two line patch that fixes it.  Any chance of a suitable
RPM set for Fedora Core 3 test 1?   Regards, Bevis.
Comment 4 H.J. Lu 2004-10-11 13:04:42 EDT
2.6.8-1.603 is OK.

Note You need to log in before you can comment on or make changes to this bug.