Bug 1300044 - Failure to reconnect when connection lost during message acknowlegement
Failure to reconnect when connection lost during message acknowlegement
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
urgent Severity urgent
: async
: 5.0 (RHEL 6)
Assigned To: Eoghan Glynn
Yurii Prokulevych
: GSSTriaged, Triaged, ZStream
Depends On: 1278177 1280019
Blocks: 1278176
  Show dependency treegraph
 
Reported: 2016-01-19 15:06 EST by Lon Hohberger
Modified: 2016-03-23 10:27 EDT (History)
16 users (show)

See Also:
Fixed In Version: openstack-ceilometer-2014.1.5-3.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1280019
Environment:
Last Closed: 2016-03-23 10:27:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Yurii Prokulevych 2016-03-22 06:28:44 EDT
Verified in openstack-ceilometer*-2014.1.5-3.el6ost.noarch

Excerpt from ceilometer/collector.log:2016-03-22 11:21:54.845 85711 ERROR ceilometer.openstack.common.rpc.common [-] Failed to consume message from queue: [Errno 32] Broken pipe
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common Traceback (most recent call last):
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/ceilometer/openstack/common/rpc/impl_kombu.py", line 616, in ensure
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     return method(*args, **kwargs)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/ceilometer/openstack/common/rpc/impl_kombu.py", line 703, in _consume
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     return self.connection.drain_events(timeout=timeout)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/kombu/connection.py", line 281, in drain_events
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     return self.transport.drain_events(self.connection, **kwargs)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/kombu/transport/pyamqp.py", line 94, in drain_events
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     return connection.drain_events(**kwargs)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/amqp/connection.py", line 288, in drain_events
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     return amqp_method(channel, args, content)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/amqp/channel.py", line 1886, in _basic_deliver
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     fun(msg)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/ceilometer/openstack/common/rpc/impl_kombu.py", line 213, in _callback
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     self._callback_handler(message, callback)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/ceilometer/openstack/common/rpc/impl_kombu.py", line 189, in _callback_handler
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     message.ack()
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/kombu/transport/base.py", line 95, in ack
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     self.channel.basic_ack(self.delivery_tag)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/amqp/channel.py", line 1565, in basic_ack
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     self._send_method((60, 80), args)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/amqp/abstract_channel.py", line 58, in _send_method
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     self.channel_id, method_sig, args, content,
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/amqp/method_framing.py", line 224, in write_method
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     write_frame(1, channel, payload)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/amqp/transport.py", line 160, in write_frame
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     pack('>BHI%dsB' % size, frame_type, channel, size, payload, 0xce),
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/eventlet/greenio.py", line 310, in sendall
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     tail = self.send(data, flags)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common   File "/usr/lib/python2.6/site-packages/eventlet/greenio.py", line 295, in send
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common     total_sent += fd.send(data[total_sent:], flags)
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common error: [Errno 32] Broken pipe
2016-03-22 11:21:54.845 85711 TRACE ceilometer.openstack.common.rpc.common
2016-03-22 11:21:54.846 85711 INFO ceilometer.openstack.common.rpc.common [-] Reconnecting to AMQP server on 10.34.75.91:5672
2016-03-22 11:21:54.847 85711 INFO ceilometer.openstack.common.rpc.common [-] Delaying reconnect for 1.0 seconds...
2016-03-22 11:21:55.852 85711 DEBUG ceilometer.dispatcher.database [req-70e6c83a-136f-44bc-976a-b3215b9d6116 - - - - -] metering data volume for bb41ee2a-f591-46c7-84ef-0d50814ce2cf @ 2016-03-22 10:21:54.829709:
 1 record_metering_data /usr/lib/python2.6/site-packages/ceilometer/dispatcher/database.py:56
2016-03-22 11:21:55.859 85711 INFO ceilometer.openstack.common.rpc.common [-] Connected to AMQP server on 10.34.75.91:5672
Comment 4 errata-xmlrpc 2016-03-23 10:27:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0498.html

Note You need to log in before you can comment on or make changes to this bug.