Bug 1300045 - Syncing images/isos for disconnected requires post-processing
Syncing images/isos for disconnected requires post-processing
Status: CLOSED DUPLICATE of bug 1300046
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: doc-Release_Notes (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.0
Assigned To: rhci-docs
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 15:06 EST by Jesus M. Rodriguez
Modified: 2016-04-29 12:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 10:27:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesus M. Rodriguez 2016-01-19 15:06:37 EST
Customers will follow the instructions for setting a synchronization host for synchronizing content for a Disconnected Satellite.

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/User_Guide/sect-Disconnected_Satellite.html

Unfortunately, pulp (the backing server hosting the content) does not export ISO/images to a directory structure friendly for use by RHCI as a CDN. The ISO/images are put in a top directory cf-me-5_4-for-rhel-6-files--x86_64/ instead of being in the content/ directory.

Pulp is adding support for this, but in the mean time we need to document that after exporting and expanding the content:

# katello-disconnected export -t /var/tmp/export
# ./expand_export.sh
*** Done expanding archives. ***

The user needs to post process the results with the following commands:

EXPORT_DIR=/var/tmp/export

# fix cf-me image files
mkdir -p $EXPORT_DIR/content/dist/cf-me/server/5.5/x86_64/files/
mkdir -p $EXPORT_DIR/content/dist/cf-me/server/5.4/x86_64/files/

mv cf-me-5_5-for-rhel-7-files--x86_64/* $EXPORT_DIR/content/dist/cf-me/server/5.5/x86_64/files/

mv cf-me-5_4-for-rhel-6-files--x86_64/* $EXPORT_DIR/content/dist/cf-me/server/5.4/x86_64/files/

# fix openstack directory files
mkdir -p $EXPORT_DIR/content/dist/rhel/server/7/7Server/x86_64/openstack-director/7.0/files/
mv rhel-7-server-openstack-7_0-files-7Server-x86_64/* $EXPORT_DIR/content/dist/rhel/server/7/7Server/x86_64/openstack-director/7.0/files/

# recursively fix openstack listing files
fix_listing_files $EXPORT_DIR/content/dist/rhel/server/7/7Server/x86_64/openstack-director/7.0/ true
Comment 1 Jesus M. Rodriguez 2016-01-20 10:27:06 EST

*** This bug has been marked as a duplicate of bug 1300046 ***

Note You need to log in before you can comment on or make changes to this bug.