Bug 1300056 - Kubelet dies if systemd-journald service is stopped
Kubelet dies if systemd-journald service is stopped
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kubernetes (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 15:43 EST by Andy Goldstein
Modified: 2016-06-24 07:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-15 09:19:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Goldstein 2016-01-19 15:43:44 EST
Description of problem: Kubelet dies if systemd-journald service is stopped


Version-Release number of selected component (if applicable):

systemd-219-19.el7.x86_64
kubernetes-master-1.0.3-0.2.gitb9a88a7.el7.x86_64
kubernetes-client-1.0.3-0.2.gitb9a88a7.el7.x86_64
kubernetes-node-1.0.3-0.2.gitb9a88a7.el7.x86_64
kubernetes-1.0.3-0.2.gitb9a88a7.el7.x86_64


How reproducible: 100%


Steps to Reproduce:
1. systemctl start kubelet
2. systemctl stop systemd-journald
3. wait a short amount of time

Actual results: kubelet is no longer running


Expected results: kubelet should remain running


Additional info:
Comment 2 Mike McGrath 2016-01-20 13:24:58 EST
One additional note here, it could very well be that docker is the issue here, we know it dies and perhaps its taking the kubelet down.
Comment 3 Jan Chaloupka 2016-06-15 09:19:38 EDT

*** This bug has been marked as a duplicate of bug 1300076 ***

Note You need to log in before you can comment on or make changes to this bug.