Bug 1300059 - Pulp requires celery >= 3.1.11, but only 3.1.9 is available in Rawhide
Pulp requires celery >= 3.1.11, but only 3.1.9 is available in Rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulp (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 15:55 EST by Randy Barlow
Modified: 2016-01-19 17:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 17:33:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2016-01-19 15:55:12 EST
Description of problem:
Celery 3.1.11 introduced some Worker heartbeat features that Pulp depends on:

http://docs.celeryproject.org/en/latest/changelog.html#version-3-1-11

Unfortunately, Rawhide only has 3.1.9 available. The latest upstream release is currently 3.1.19. Hopefully we can work with the package maintainer to get it updated to a new enough release for us.

Without this, it is impossible to start the Pulp workers:

$ sudo systemctl start pulp_workers
$ sudo systemctl status pulp_worker-0
● pulp_worker-0.service - Pulp Worker #0
   Loaded: loaded (/run/systemd/system/pulp_worker-0.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2016-01-19 15:41:41 EST; 12min ago
  Process: 2710 ExecStart=/usr/bin/celery worker -n reserved_resource_worker-0@%%h -A pulp.server.async.app -c 1 --ev
 Main PID: 2710 (code=exited, status=2)

Jan 19 15:41:39 boole.usersys.redhat.com systemd[1]: Started Pulp Worker #0.
Jan 19 15:41:40 boole.usersys.redhat.com celery[2710]: Usage: celery worker [options]
Jan 19 15:41:40 boole.usersys.redhat.com celery[2710]: celery: error: no such option: --heartbeat-interval
Jan 19 15:41:41 boole.usersys.redhat.com systemd[1]: pulp_worker-0.service: Main process exited, code=exited, status=
Jan 19 15:41:41 boole.usersys.redhat.com systemd[1]: pulp_worker-0.service: Unit entered failed state.
Jan 19 15:41:41 boole.usersys.redhat.com systemd[1]: pulp_worker-0.service: Failed with result 'exit-code'.
Comment 1 Randy Barlow 2016-01-19 16:07:28 EST
I am going to mark Pulp with the appropriate Requires, which will block it from installing until this is fixed.
Comment 2 Randy Barlow 2016-01-19 16:47:43 EST
bmbouter graciously bumped us to 3.1.11. Getting it to 3.1.19 will be more effort, but we are unblocked.

http://koji.fedoraproject.org/koji/buildinfo?buildID=712383
Comment 3 Randy Barlow 2016-01-19 17:33:56 EST
I've raised the Requires statement in this build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=12612610

In tomorrow's Rawhide, Pulp *should* have a celery it can work with.

Note You need to log in before you can comment on or make changes to this bug.