Red Hat Bugzilla – Bug 1300059
Pulp requires celery >= 3.1.11, but only 3.1.9 is available in Rawhide
Last modified: 2016-01-19 17:33:56 EST
Description of problem:
Celery 3.1.11 introduced some Worker heartbeat features that Pulp depends on:
Unfortunately, Rawhide only has 3.1.9 available. The latest upstream release is currently 3.1.19. Hopefully we can work with the package maintainer to get it updated to a new enough release for us.
Without this, it is impossible to start the Pulp workers:
$ sudo systemctl start pulp_workers
$ sudo systemctl status pulp_worker-0
● pulp_worker-0.service - Pulp Worker #0
Loaded: loaded (/run/systemd/system/pulp_worker-0.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Tue 2016-01-19 15:41:41 EST; 12min ago
Process: 2710 ExecStart=/usr/bin/celery worker -n reserved_resource_worker-0@%%h -A pulp.server.async.app -c 1 --ev
Main PID: 2710 (code=exited, status=2)
Jan 19 15:41:39 boole.usersys.redhat.com systemd: Started Pulp Worker #0.
Jan 19 15:41:40 boole.usersys.redhat.com celery: Usage: celery worker [options]
Jan 19 15:41:40 boole.usersys.redhat.com celery: celery: error: no such option: --heartbeat-interval
Jan 19 15:41:41 boole.usersys.redhat.com systemd: pulp_worker-0.service: Main process exited, code=exited, status=
Jan 19 15:41:41 boole.usersys.redhat.com systemd: pulp_worker-0.service: Unit entered failed state.
Jan 19 15:41:41 boole.usersys.redhat.com systemd: pulp_worker-0.service: Failed with result 'exit-code'.
I am going to mark Pulp with the appropriate Requires, which will block it from installing until this is fixed.
bmbouter graciously bumped us to 3.1.11. Getting it to 3.1.19 will be more effort, but we are unblocked.
I've raised the Requires statement in this build:
In tomorrow's Rawhide, Pulp *should* have a celery it can work with.