Bug 1300064 - SELinux is preventing chmod from 'setattr' accesses on the file cmd.
SELinux is preventing chmod from 'setattr' accesses on the file cmd.
Status: CLOSED DUPLICATE of bug 1300066
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b59e5d569b4cc5b48c60376645b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 16:13 EST by edo
Modified: 2016-01-20 04:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 04:42:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description edo 2016-01-19 16:13:16 EST
Description of problem:
SELinux is preventing chmod from 'setattr' accesses on the file cmd.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that chmod should be allowed setattr access on the cmd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep chmod /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_mail_t:s0
Target Context                system_u:object_r:root_t:s0
Target Objects                cmd [ file ]
Source                        chmod
Source Path                   chmod
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.2.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.3.3-301.fc23.x86_64 #1 SMP Fri
                              Jan 15 14:03:17 UTC 2016 x86_64 x86_64
Alert Count                   18
First Seen                    2016-01-18 11:30:29 CET
Last Seen                     2016-01-19 21:57:21 CET
Local ID                      58646453-a5d6-4bf0-b190-49ddb2591dfc

Raw Audit Messages
type=AVC msg=audit(1453237041.165:676): avc:  denied  { setattr } for  pid=3034 comm="chmod" name="cmd" dev="dm-0" ino=2752567 scontext=system_u:system_r:system_mail_t:s0 tcontext=system_u:object_r:root_t:s0 tclass=file permissive=1


Hash: chmod,system_mail_t,root_t,file,setattr

Version-Release number of selected component:
selinux-policy-3.13.1-158.2.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.3-301.fc23.x86_64
type:           libreport

Potential duplicate: bug 1239279
Comment 1 Lukas Vrabec 2016-01-20 04:42:50 EST

*** This bug has been marked as a duplicate of bug 1300066 ***

Note You need to log in before you can comment on or make changes to this bug.