Bug 1300067 - SELinux is preventing sendmail from 'getattr' accesses on the file /.esmtp_queue/tVUDTHp0/cmd.
SELinux is preventing sendmail from 'getattr' accesses on the file /.esmtp_qu...
Status: CLOSED DUPLICATE of bug 1300065
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-01-19 16:15 EST by edo
Modified: 2016-01-20 04:44 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-20 04:44:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description edo 2016-01-19 16:15:51 EST
Description of problem:
SELinux is preventing sendmail from 'getattr' accesses on the file /.esmtp_queue/tVUDTHp0/cmd.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/.esmtp_queue/tVUDTHp0/cmd default label should be default_t.
Then you can run restorecon.
# /sbin/restorecon -v /.esmtp_queue/tVUDTHp0/cmd

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that sendmail should be allowed getattr access on the cmd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# grep sendmail /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_mail_t:s0
Target Context                system_u:object_r:root_t:s0
Target Objects                /.esmtp_queue/tVUDTHp0/cmd [ file ]
Source                        sendmail
Source Path                   sendmail
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.2.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.3.3-301.fc23.x86_64 #1 SMP Fri
                              Jan 15 14:03:17 UTC 2016 x86_64 x86_64
Alert Count                   18
First Seen                    2016-01-18 11:30:29 CET
Last Seen                     2016-01-19 21:57:21 CET
Local ID                      a870f8ca-0491-4885-b504-eb89bd2f3554

Raw Audit Messages
type=AVC msg=audit(1453237041.161:675): avc:  denied  { getattr } for  pid=3025 comm="sendmail" path="/.esmtp_queue/tVUDTHp0/cmd" dev="dm-0" ino=2752567 scontext=system_u:system_r:system_mail_t:s0 tcontext=system_u:object_r:root_t:s0 tclass=file permissive=1

Hash: sendmail,system_mail_t,root_t,file,getattr

Version-Release number of selected component:

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.3-301.fc23.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2016-01-20 04:44:07 EST

*** This bug has been marked as a duplicate of bug 1300065 ***

Note You need to log in before you can comment on or make changes to this bug.