Bug 1300080 - odd behavior sorting automate domains
odd behavior sorting automate domains
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.4.5
Assigned To: Harpreet Kataria
Pete Savage
ui:automate
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 17:27 EST by Josh Carter
Modified: 2016-03-29 10:17 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
Previously, there was an issue when sorting automate domains where they were not being sorted the same way on the left side of the UI, when compared to the right side. This patch fixes the tree building & right cell code to order Domain by Priority Desc which has now resolved the issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 10:17:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Carter 2016-01-19 17:27:29 EST
Description of problem:

domains are not being sorted the same in the left side of the ui compared to the right side 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 CFME Bot 2016-01-21 12:19:25 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1520fa744706db6a0958dbadd1734d27a3a3e55c

commit 1520fa744706db6a0958dbadd1734d27a3a3e55c
Merge: d8bf7e3 acd52a4
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Jan 21 12:03:29 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Jan 21 12:03:29 2016 -0500

    Merge branch '54z_bz_1300080' into '5.4.z'
    
    Fixed tree building & right cell code to order Domain by Priority Desc
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300080
    
    @dclarizi please review, this is a 5.4.z only fix. Code has been updated/refactored on upstream & 5.5.z branches so this is not an issue on those two branches.
    
    before:
    ![before_1](http://gitlab.cloudforms.lab.eng.rdu2.redhat.com/hkataria/cfme/uploads/4af8108dfeef7c4a347bf9611bd1c71d/before_1.png)
    
    ![before_2](http://gitlab.cloudforms.lab.eng.rdu2.redhat.com/hkataria/cfme/uploads/ad6f42691cfffeeae3e09d7013f15697/before_2.png)
    
    after:
    
    ![after_1](http://gitlab.cloudforms.lab.eng.rdu2.redhat.com/hkataria/cfme/uploads/ca5e875a712ac04fbca9a34f1d30ac68/after_1.png)
    
    ![after_2](http://gitlab.cloudforms.lab.eng.rdu2.redhat.com/hkataria/cfme/uploads/94814638539f79d590a8b833f04f2ace/after_2.png)
    
    
    See merge request !739

 vmdb/app/controllers/miq_ae_class_controller.rb | 4 ++--
 vmdb/app/presenters/tree_builder_ae_class.rb    | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 6 CFME Bot 2016-01-21 12:19:29 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=acd52a402aab5e51d2b85ac9216525f69ad6456a

commit acd52a402aab5e51d2b85ac9216525f69ad6456a
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Jan 20 16:09:20 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Jan 20 16:09:20 2016 -0500

    Fixed tree building & right cell code to order Domain by Priority Desc
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300080

 vmdb/app/controllers/miq_ae_class_controller.rb | 4 ++--
 vmdb/app/presenters/tree_builder_ae_class.rb    | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 8 Pete Savage 2016-03-18 13:36:15 EDT
Verified in 5.4.5.2
Comment 10 errata-xmlrpc 2016-03-29 10:17:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.