Bug 1300173 - Unable to resize/move windows via keyboard in GNOME on Wayland session.
Unable to resize/move windows via keyboard in GNOME on Wayland session.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2016-01-20 01:43 EST by Alexandr
Modified: 2016-09-01 03:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-01 03:35:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandr 2016-01-20 01:43:26 EST
Description of problem:
Unable to resize/move windows via keyboard in 'GNOME on Wayland' session.

Version-Release number of selected component (if applicable):
gnome-session-wayland-session.x86_64  3.18.1.2-2.fc23                  
ibus-wayland.x86_64                   1.5.11-1.fc23                
libwayland-client.i686                1.9.0-1.fc23                     
libwayland-client.x86_64              1.9.0-1.fc23                     
libwayland-cursor.x86_64              1.9.0-1.fc23                      
libwayland-server.i686                1.9.0-1.fc23                     
libwayland-server.x86_64              1.9.0-1.fc23                     
mesa-libwayland-egl.x86_64            11.1.0-2.20151218.fc23           
gnome-desktop3.x86_64                 3.18.2-1.fc23                     
gtk3.x86_64                           3.18.6-1.fc23

How reproducible:


Steps to Reproduce:
1. Settings->keyboard->Shortcuts->windows Bind shortcut to Move and resize window(in my case Super+M and Super+R)
2. Login with gnome wayland session
3. Press shortcut to resize/move window and press arrow-left/right/up/down

Actual results:
Resize/move mode turned on, but arrows doesn't affecting windows size or position, it works only with touchpad/mouse.

Expected results:
Resize/move mode turned on. Arrows affecting windows size or position.

Additional info:
Works in GNOME session.
Comment 1 Olivier Fourdan 2016-02-19 09:33:07 EST
That's a GNOME issue (in mutter) rather than Wayland.
Comment 2 Christian Stadelmann 2016-04-02 05:26:14 EDT
I cannot reproduce this issue and have been using Gnome+Wayland for a while. There is something special with your (hardware or software) configuration needed to track this issue down. I just don't know what.
Comment 3 Olivier Fourdan 2016-04-13 10:54:09 EDT
I can reproduce the problem on a pristine even on a F24 install, it behaves as if once the shortcut has triggered the move/resize operation, no keyboard event is processed anymore, not the arrows to move, nor space to validate nor escape to cancel. 

Basically, keys simply don't work when using the move or resize shortcuts in mutter/gnome-shell on Wayland.
Comment 4 Olivier Fourdan 2016-04-18 08:43:12 EDT
Neither process_keyboard_move_grab() nor process_keyboard_resize_grab() get called from process_key_event(), that's because "all_keys_grabbed" is FALSE.

Can't find a corresponding upstream bug for that, will file one and continue from there.
Comment 5 Olivier Fourdan 2016-04-18 08:45:10 EDT
Ah, here it is: https://bugzilla.gnome.org/show_bug.cgi?id=758076
Comment 6 Olivier Fourdan 2016-04-19 03:19:36 EDT
A fix for this bug has been pushed upstream:

https://git.gnome.org/browse/mutter/commit/?id=5d6af70

Note You need to log in before you can comment on or make changes to this bug.