Bug 1300221 - cannot disable user
Summary: cannot disable user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: sankarshan
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-20 10:03 UTC by Martin Kudlej
Modified: 2016-08-23 19:46 UTC (History)
3 users (show)

Fixed In Version: rhscon-ui-0.0.19-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:46:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-01-20 10:03:46 UTC
Description of problem:
It is not possible to disable user from UI.

Version-Release number of selected component (if applicable):
rhscon-ui-0.0.6-0.1.alpha1.el7.noarch
rhscon-core-0.0.6-0.1.alpha1.el7.x86_64
rhscon-ceph-0.0.4-0.1.alpha1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
in user list
1. click "More" and "Disable User"
2. status icon has changed but user status has not been changed on server(GET /users still returns user with status:true)

in user edit:
1. click "More" and "Edit User"
2. uncheck "Enabled" and click "Save"
3. status has not been changed on server(GET /users still returns user with status:true)

Actual results:
User cannot be disabled from UI.

Expected results:
User can be disabled from UI.

Comment 1 Martin Kudlej 2016-01-20 10:13:09 UTC
It is not possible to disable email notifications from "Edit User" form. I think it is connected to this issue.

Comment 2 Martin Kudlej 2016-01-20 10:16:40 UTC
Also I've realized that there is similar issue with disabling and enabling email notifications from list of users:
1. click "More" and "Enable Notification" or "Disable Notification"
2. state on server has not changed

Comment 3 Martin Kudlej 2016-01-20 15:41:04 UTC
I see similar issue with changing notification property in:
Icons in right upper corner-> right icon->Change Password
Changing notification property in this form and clock on "Save" has not effect.

Comment 4 Dhivya Sivaprakasam 2016-02-12 05:48:37 UTC
https://review.gerrithub.io/#/c/262834/

Comment 7 Martin Kudlej 2016-07-01 10:50:27 UTC
Tested with rhscon-ui-0.0.43-1.el7scon.noarch and it works. -> VERIFIED

Comment 10 errata-xmlrpc 2016-08-23 19:46:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.