Bug 1300223 - perl-IPTables-libiptc-0.52-13.fc24 FTBFS: redeclaration of enumerator 'IFF_UP'
perl-IPTables-libiptc-0.52-13.fc24 FTBFS: redeclaration of enumerator 'IFF_UP'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-IPTables-libiptc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
: 1307851 (view as bug list)
Depends On: 1300256
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-01-20 05:04 EST by Petr Pisar
Modified: 2016-02-18 07:22 EST (History)
4 users (show)

See Also:
Fixed In Version: perl-IPTables-libiptc-0.52-15.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 07:22:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-01-20 05:04:38 EST
perl-IPTables-libiptc-0.52-13.fc24 fails to build in F24:

make[1]: Entering directory '/builddir/build/BUILD/IPTables-libiptc-0.52/iptables'
cc -O2 -Wall -Wunused -I/include -I/usr/include -I../include/ -fPIC -DXTABLES_INTERNAL -g -DIPTABLES_VERSION=\"1.4.21\" -DXTABLES_LIBDIR=\"/usr/libexec/xtables\" -DIPTABLES_VERSION_CODE=\66581 -c -o iptables.o iptables-detect-version.c
iptables-detect-version.c:57:2: warning: #warning "This version of xtables is currently not supported by this Perl package" [-Wcpp]
 #warning "This version of xtables is currently not supported by this Perl package"
  ^
iptables-detect-version.c:57:2: warning: #warning "This version of xtables is currently not supported by this Perl package" [-Wcpp]
 #warning "This version of xtables is currently not supported by this Perl package"
  ^
Running Mkbootstrap for IPTables::libiptc ()
In file included from /usr/include/xtables.h:16:0,
                 from iptables-detect-version.c:2:
/usr/include/linux/if.h:71:2: error: redeclaration of enumerator 'IFF_UP'
  IFF_UP    = 1<<0,  /* sysfs */
  ^
/usr/include/net/if.h:44:5: note: previous definition of 'IFF_UP' was here
     IFF_UP = 0x1,  /* Interface is up.  */
     ^

Difference betweem working and failing build root:

        perl-podlators 	4.04-1.fc24 	> 	4.05-1.fc24
	glib2 	2.47.4-1.fc24 	> 	2.47.5-1.fc24
	systemtap-sdt-devel 	3.0-0.20160111git... 	> 	3.0-0.20160118git...
	ncurses 	6.0-1.20150810.fc24 	> 	6.0-2.20160116.fc24
	libtool-ltdl 	2.4.6-7.fc24 	> 	2.4.6-8.fc24
	ncurses-libs 	6.0-1.20150810.fc24 	> 	6.0-2.20160116.fc24
	device-mapper-libs 	1.02.114-2.fc24 	> 	1.02.114-3.fc24
	libfdisk 	2.27.1-3.fc24 	> 	2.27.1-4.fc24
	device-mapper 	1.02.114-2.fc24 	> 	1.02.114-3.fc24
	python3-setuptools 	19.2-2.fc24 	> 	19.4-1.fc24
	libuuid 	2.27.1-3.fc24 	> 	2.27.1-4.fc24
	ncurses-base 	6.0-1.20150810.fc24 	> 	6.0-2.20160116.fc24
	libblkid 	2.27.1-3.fc24 	> 	2.27.1-4.fc24
	kernel-headers 	4.5.0-0.rc0.git1.1.... 	> 	4.5.0-0.rc0.git5.1....
	nspr 	4.10.10-2.fc24 	> 	4.11.0-1.fc24
	ncurses-compat-libs 	6.0-1.20150810.fc24 	> 	6.0-2.20160116.fc24
	util-linux 	2.27.1-3.fc24 	> 	2.27.1-4.fc24
	libmount 	2.27.1-3.fc24 	> 	2.27.1-4.fc24
	libsmartcols 	2.27.1-3.fc24 	> 	2.27.1-4.fc24

This is caused by upgrading kernel-headers.
Comment 1 Petr Pisar 2016-02-15 03:45:48 EST
*** Bug 1307851 has been marked as a duplicate of this bug. ***
Comment 2 Petr Pisar 2016-02-18 07:22:10 EST
I applied a work around that prevents from including <net/if.h>.

Note You need to log in before you can comment on or make changes to this bug.