Bug 1300225 - cmake arguments are not correct
cmake arguments are not correct
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libical (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 05:06 EST by Milan Crha
Modified: 2016-01-21 10:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 14:53:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Crha 2016-01-20 05:06:55 EST
I was rebuilding libical recently and I tried to use arguments shown in the build log [1] in my local build and override the lib directory, but it didn't work. I asked on their list, thinking it's and issue on their side, but the developer pointed me out that it me doing things wrong [2]. In short, koji uses 

   -DLIB_INSTALL_DIR:PATH=/usr/lib

but the correct variable to be used, according to the libical developer [2], is

   -DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib

The later looks like the correct variable, a standard one for cmake, thus I'd add it (not replace, to not break things) it to the argument list of the cmake build command.

[1] https://kojipkgs.fedoraproject.org//packages/libical/2.0.0/2.fc24/data/logs/x86_64/build.log

[2] http://lists.infradead.org/pipermail/libical-devel/2016-January/000654.html
Comment 1 Dennis Gilmore 2016-01-20 12:03:12 EST
there is nothing that could possibly be changed in koji to fix this, reassigning to libical
Comment 2 Rex Dieter 2016-01-20 14:53:16 EST
http://pkgs.fedoraproject.org/cgit/rpms/libical.git/tree/libical.spec

Doesn't explicitly set or use either of those, so NOTABUG.

Feel free to customize it as you see fit (using the correct CMAKE_INSTALL_LIBDIR here)
Comment 3 Milan Crha 2016-01-21 03:47:52 EST
(In reply to Dennis Gilmore from comment #1)
> there is nothing that could possibly be changed in koji to fix this,
> reassigning to libical

Ehm, my fault, the CMAKE_ prefix of the variable made me think that the libical uses a standard cmake variable, but there is no such available [1]. I didn't verify that before posting this bug report. I'm sorry.

Otherwise my rant was meant for a build system, which is koji from my point of view, to add the variable into the command line. My request is invalid, as the variable is unknown to cmake.

[1] for cmake 3.4.1, the below command returns nothing:
    $ cmake --help-variable-list | grep LIBDIR
Comment 4 Rex Dieter 2016-01-21 10:33:32 EST
See:
https://cmake.org/cmake/help/v3.4/module/GNUInstallDirs.html

for what libical uses and supports currently (its CMakeLists.txt uses this module)

Note You need to log in before you can comment on or make changes to this bug.