This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1300238 - rhel6 guest's resolution will be restored automatically when changing resolution from high to low in display preferences
rhel6 guest's resolution will be restored automatically when changing resolut...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.8
x86_64 Unspecified
medium Severity low
: rc
: ---
Assigned To: Pavel Grunt
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 05:28 EST by mxie@redhat.com
Modified: 2016-10-10 03:24 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-10 03:24:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log1 (83.68 KB, text/plain)
2016-01-20 05:28 EST, mxie@redhat.com
no flags Details
log2 (114.08 KB, text/plain)
2016-01-26 05:34 EST, mxie@redhat.com
no flags Details

  None (edit)
Description mxie@redhat.com 2016-01-20 05:28:19 EST
Created attachment 1116574 [details]
log1

Description of problem:
rhel6 guest's resolution will be restored automatically when changing resolution from high to low in display preferences

Version-Release number of selected component (if applicable):
virt-viewer-2.0-12.el6.x86_64
xorg-x11-drv-qxl-0.1.1-17.el6.x86_64
Guest kernel:2.6.32-573.el6.x86_64
Guest pkg:spice-vdagent-0.14.0-9.el6.x86_64

How reproducible:
50%

Steps to Reproduce:
1.Prepare a rhel6 spicevmc+spice+qxl guest and service spice-vdagentd is running

2.use virt-viewer connect to the guest, the details debug info please refer to attachment log1

# virt-viewer rhel6released --debug --spice-debug
(virt-viewer:20903): GSpice-DEBUG: channel-inputs.c:340 inputs-3:0: over SPICE_INPUT_MOTION_ACK_BUNCH * 2, dropping
(virt-viewer:20903): GSpice-DEBUG: channel-inputs.c:340 inputs-3:0: over SPICE_INPUT_MOTION_ACK_BUNCH * 2, dropping
(virt-viewer:20903): GSpice-DEBUG: channel-inputs.c:340 inputs-3:0: over SPICE_INPUT_MOTION_ACK_BUNCH * 2, dropping

3.Setting rhel6 guest resolution as 1920*1440 in display preferences

4.Changing rhel6 guest's as 1024*600 in display preferences, then rhel6 guest's resolution will be restored to 1920*1440 automatically

Actual results:
As above description

Expected results:
Could change rhel6 guest's resolution normally in display preferences


Addtional info:
1.It is easier to reproduced the bug by changing a large range resolution, such as "2000*2000 -> 1280x720", "1600x1200->960x640"
Comment 1 Fabiano Fidêncio 2016-01-20 05:33:57 EST
I could reproduce the very same issue using upstream client.

Would you mind to let us know if it's a regression or a new bug?
Does it happen with RHEL-7 guest as well?
Comment 3 mxie@redhat.com 2016-01-20 23:30:34 EST
(In reply to Fabiano Fidêncio from comment #1)
> I could reproduce the very same issue using upstream client.
> 
> Would you mind to let us know if it's a regression or a new bug?
> Does it happen with RHEL-7 guest as well?

Hi Fidencio,

This bug can't be reproduced on rhel7 guest and the bug could be fixed after downgrade version of virt-viewer to virt-viewer-2.0-7.el6.x86_64, so it is a regression, thanks
Comment 4 Pavel Grunt 2016-01-21 09:43:21 EST
Hi,
What is your client resolution?
Isn't the window attached to an edge? It can happen after doubleclicking the window title bar. if so the window manager is preventing the window to resize.
Comment 5 mxie@redhat.com 2016-01-21 22:52:17 EST
(In reply to Pavel Grunt from comment #4)
> Hi,
> What is your client resolution?
> Isn't the window attached to an edge? It can happen after doubleclicking the
> window title bar. if so the window manager is preventing the window to
> resize.

Hi Grunt,

My host resolution is 1680x1050, and if I set my guest's resolution from 1624x917 (guest's window is not attached to monitor's edge ) to 640x480, resolution will be restored to 1624x917 accidentally, is above info you need ?
Comment 6 Pavel Grunt 2016-01-22 03:46:18 EST
> 
> Hi Grunt,
> 
> My host resolution is 1680x1050, and if I set my guest's resolution from
> 1624x917 (guest's window is not attached to monitor's edge ) to 640x480,
> resolution will be restored to 1624x917 accidentally, is above info you need
> ?

I am still unable to reproduce.
Can you reproduce it with any rhel6 guest?
How the vm was created - using default options of virt-manager ?
Can you provide qemu commandline or xml definition ?

Thanks
Comment 7 Fabiano Fidêncio 2016-01-22 12:51:53 EST
I just would like to comment that I spent a few time trying to reproduce the issue but, for some reason, I am not able to reproduce it anymore :-\

mxie, perhaps you could give access to the guest VM to Pavel.
Comment 9 Pavel Grunt 2016-01-26 04:54:41 EST
Hi, I can reproduce the bug only as the root. Please reproduce the bug as a non root user. Do not run the whole desktop/session as the root superuser. And add the full xml definition. Thanks
Comment 10 mxie@redhat.com 2016-01-26 05:33:54 EST
(In reply to Pavel Grunt from comment #9)
> Hi, I can reproduce the bug only as the root. Please reproduce the bug as a
> non root user. Do not run the whole desktop/session as the root superuser.
> And add the full xml definition. Thanks

Hi pgrunt
 
I can reproduce the bug as a non root user

Steps:
1.Log in to non root user 
2.virt-viewer -c qemu:///system rhel6released

Below is guest rhel6released's xml:
# virsh dumpxml rhel67released
<domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>
  <name>rhel67released</name>
  <uuid>6ef8b52f-a9e7-7025-bc66-2de06e103c65</uuid>
  <memory unit='KiB'>1048576</memory>
  <currentMemory unit='KiB'>1048576</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <os>
    <type arch='x86_64' machine='rhel6.6.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source file='/var/lib/libvirt/images/rhel67released.img'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </disk>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x7'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0' multifunction='on'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x1'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x2'/>
    </controller>
    <controller type='virtio-serial' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
    </controller>
    <interface type='network'>
      <mac address='52:54:00:22:cd:62'/>
      <source network='default'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
    <interface type='network'>
      <mac address='52:54:00:9a:c5:71'/>
      <source network='test'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x09' function='0x0'/>
    </interface>
    <serial type='pty'>
      <target port='0'/>
    </serial>
    <console type='pty'>
      <target type='serial' port='0'/>
    </console>
    <channel type='spicevmc'>
      <target type='virtio' name='com.redhat.spice.0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    </channel>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='spice' port='5908' autoport='no' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
    <sound model='es1370'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </sound>
    <video>
      <model type='qxl' ram='262144' vram='131072' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <redirdev bus='usb' type='spicevmc'>
    </redirdev>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0'/>
    </memballoon>
  </devices>
  <qemu:commandline>
    <qemu:arg value='-global'/>
    <qemu:arg value='qxl-vga.vgamem_mb=64'/>
  </qemu:commandline>
</domain>

and logs from the user session, please refer to attachment log2
Thanks
Comment 11 mxie@redhat.com 2016-01-26 05:34 EST
Created attachment 1118432 [details]
log2
Comment 12 Pavel Grunt 2016-01-27 04:51:58 EST
I managed to reproduce it with any version of virt-viewer - it is not a regression (at least not on the virt-viewer side).

It seems that the key is the change of the desktop aspect ratio:

1440x900 => 16:10
640x480  => 4:3

Sometimes the window does not resize quickly enough (for me the it is 10% reproducible) and following appears in the debug log:
(virt-viewer:1794): virt-viewer-DEBUG: Allocated 1440x900
(virt-viewer:1794): virt-viewer-DEBUG: Child allocate 1200x900

instead of:
(virt-viewer:1794): virt-viewer-DEBUG: Allocated 640x480
(virt-viewer:1794): virt-viewer-DEBUG: Child allocate 640x480

and the bug is triggered.
Comment 14 Pavel Grunt 2016-10-03 02:46:43 EDT
Hi, are you still able to reproduce ?

I am not. It is possible that it got fixed by another component (maybe gtk2).

Version-Release number of selected component (if applicable):
virt-viewer-2.0-15.el6.x86_64
gtk2-2.24.23-8.el6.x86_64
Comment 15 mxie@redhat.com 2016-10-09 04:22:31 EDT
Hi Pavel,

I also can't reproduce the problem right now

Version-Release number of selected component (if applicable):
virt-viewer-2.0-15.el6.x86_64
gtk2-2.24.23-8.el6.x86_64
Comment 16 Pavel Grunt 2016-10-10 03:24:37 EDT
(In reply to mxie@redhat.com from comment #15)
> Hi Pavel,
> 
> I also can't reproduce the problem right now
> 
> Version-Release number of selected component (if applicable):
> virt-viewer-2.0-15.el6.x86_64
> gtk2-2.24.23-8.el6.x86_64

Thank you for the confirmation! Closing

Note You need to log in before you can comment on or make changes to this bug.