Bug 1300253 - Test open-behind.t failing fairly often on NetBSD
Test open-behind.t failing fairly often on NetBSD
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: open-behind (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Prasanna Kumar Kalever
: Triaged
Depends On:
Blocks: 1353736 1334204
  Show dependency treegraph
 
Reported: 2016-01-20 06:03 EST by Krutika Dhananjay
Modified: 2016-07-07 16:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1334204 1353736 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-01-20 06:03:33 EST
Description of problem:
same as summary. Test will be moved to bad tests list until the problem is fixed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-01-20 06:07:14 EST
REVIEW: http://review.gluster.org/13268 (tests: Move open-behind.t to bad tests list) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2016-01-20 10:31:32 EST
COMMIT: http://review.gluster.org/13268 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 27a350fe30c03fddb57231a2a60bb3e4c54d9dd4
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Jan 20 16:35:42 2016 +0530

    tests: Move open-behind.t to bad tests list
    
    Change-Id: I505e6dbd13d7922ac7468507c172764d64256389
    BUG: 1300253
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13268
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Vijay Bellur 2016-04-01 05:29:08 EDT
REVIEW: http://review.gluster.org/13884 (tests: add open-behind.t to bad tests) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 5 Vijay Bellur 2016-04-01 10:19:17 EDT
COMMIT: http://review.gluster.org/13884 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 279c8e42ffe61d2906009a305aec3e218c058d0e
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Fri Apr 1 14:54:48 2016 +0530

    tests: add open-behind.t to bad tests
    
    open-behind.t fails on NetBSD very frequently
    will be disabled until the problem is fixed
    
    Change-Id: I0655e4b0c8b3ad7fc9e2ccfcf679673832ff12a5
    BUG: 1300253
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/13884
    Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Niels de Vos 2016-06-16 09:55:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.