Bug 1300262 - When install two RHEL7.2 on one server the old one could not boot by default
Summary: When install two RHEL7.2 on one server the old one could not boot by default
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: os-prober   
(Show other bugs)
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: rmarshall
QA Contact: Jan Ščotka
Aneta Šteflová Petrová
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-20 11:27 UTC by fine.fan
Modified: 2016-11-04 04:28 UTC (History)
3 users (show)

Fixed In Version: os-prober-1.58-8
Doc Type: Bug Fix
Doc Text:
*os-prober* now uses device mapper alias names in the boot loader configuration The *os-prober* component previously used the numeric device mapper device in the boot loader configuration. After reboot, when the installer disk image was no longer mounted, the number changed, which rendered the boot entry unusable. Consequently, when two instances of Red Hat Enterprise Linux were installed on one machine, one of them failed to boot. To fix this bug, *os-prober* now uses device mapper alias names instead of the direct enumerated device mapper names. Because the alias names are more stable, the boot entry works as expected in the described situation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:28:57 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot zip file (158.37 KB, application/zip)
2016-01-20 11:27 UTC, fine.fan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2351 normal SHIPPED_LIVE os-prober bug fix update 2016-11-03 13:47:58 UTC

Description fine.fan 2016-01-20 11:27:11 UTC
Created attachment 1116586 [details]
Screenshot zip file

Description of problem:
I have install two RHEL7.2 on one server .The grub has already contain two RHEL7.2 OS (first install the rhel72-1 OS then install the rhel72-2 OS).But when trying to boot from the rhel72-1 OS it will failed to boot up.

Version-Release number of selected component (if applicable):
rhel-server-7.2-x86_64-dvd.iso

How reproducible:
Every time

Steps to Reproduce:
1.Use a bare machine to install the RHEL7.2 OS with below partation:
   sda1   500M xfs /boot
   sda2   7G   lvm   rhel-root xfs /
          2G   lvm   rhel-swap swap
2.then use the same machine to install the second RHEL7.2 OS as below partation:
   sda3   500M  xfs /boot
   sda4   1k
   sda5   7G  lvm rhel00-root xfs /
3.waiting for the installation finished
4.select first install RHEL7.2 OS to boot

Actual results:
boot failed

Expected results:
boot success

Additional info:
The solution is fix the grub list manual :
When see the grub high light the first RHEL7.2 OS then press "e" to edit it find the “root=/dev/dm-2”entry and then fix it  into "root=/dev/mapper/rhel-root" then press "Ctrl+x" the first RHEL7.2 OS could boot normal.

I just wondering why the default grub doesn't work.

Comment 8 errata-xmlrpc 2016-11-04 04:28:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2351.html


Note You need to log in before you can comment on or make changes to this bug.