Bug 1300264 - ceilometer-dbsync fails in HA IPv6 deployment
Summary: ceilometer-dbsync fails in HA IPv6 deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: y3
: 7.0 (Kilo)
Assignee: Giulio Fidente
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-20 11:30 UTC by Marius Cornea
Modified: 2016-04-18 07:13 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-109.el7ost
Doc Type: Bug Fix
Doc Text:
'ceilometer-dbsync' fails in a highly available IPv6 Overcloud. This is due to how the director parsed IPv6 addresses for MongoDB. This fix corrects how the director parses IPv6 addresses. Now 'ceilometer-dbsync' runs successfully.
Clone Of:
Environment:
Last Closed: 2016-02-18 16:50:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 270154 None None None 2016-01-20 15:13:33 UTC
Red Hat Product Errata RHBA-2016:0264 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2016-02-18 21:41:29 UTC

Description Marius Cornea 2016-01-20 11:30:45 UTC
Description of problem:
ceilometer-dbsync fails in HA IPv6 deployment with the following error:
CRITICAL ceilometer [-] ConfigurationError: Reserved characters such as ':' must be escaped according RFC 2396. An IPv6 address literal must be enclosed in '[' and ']' according to RFC 2732.

This is how the mongo connection looks in ceilometer.conf:
connection=mongodb://fd00:fd00:fd00:2000:f816:3eff:fee0:6adc:27017,fd00:fd00:fd00:2000:f816:3eff:fe03:7f6:27017,fd00:fd00:fd00:2000:f816:3eff:fe6c:6c65:27017/ceilometer?replicaSet=tripleo


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-108.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy HA IPv6 enabled overcloud

Actual results:
Deployment fails because ceilometer-dbsync fails

Expected results:
Deployment succeeds.

Comment 1 Sofer Athlan-Guyot 2016-01-20 14:54:20 UTC
This patch seems to fix it : https://review.openstack.org/#/c/270154/

Comment 3 Marius Cornea 2016-01-21 11:30:47 UTC
openstack-tripleo-heat-templates-0.8.6-110.el7ost.noarch

Comment 5 errata-xmlrpc 2016-02-18 16:50:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html


Note You need to log in before you can comment on or make changes to this bug.