Bug 130032 - DocBook/Emacs/psgml Quickstart Guide
DocBook/Emacs/psgml Quickstart Guide
Status: CLOSED WONTFIX
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Wade
Paul W. Frields
:
Depends On:
Blocks: fedora-docs-writing
  Show dependency treegraph
 
Reported: 2004-08-16 13:58 EDT by Mark Johnson
Modified: 2009-08-05 19:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 19:48:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Johnson 2004-08-16 13:58:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Compose a "quick start" tutorial guide that addresses
DocBook/Emacs/psgml setup.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Tammy Fox 2004-08-27 16:41:07 EDT
Mark, can you provide an outline of this or a time frame?
Comment 2 Mark Johnson 2004-08-27 23:10:56 EDT
Sure.

Since I'm doing RedHat work this weekend, I'll do some fedora doc work
next week.

How about I supply a draft outline (or doc) by Tuesday 8/30, collect
bugs/feedback, and supply a pseudo-complete outline by Friday, 9/03.

Then, provide a relatively complete document draft by Wednesday, 9/08,
for everyone to critique. 

From there, I would say, give me another week to submit a revised
document based on feedback, though I may be able to produce this
version sooner. In other words, I submit a usable/postable version by 
Wednesday, 9/15.

I then go on vacation from 9/18 - 9/25.

Sound reasonable? (I'm working on it as I type this, FWIW.)
Comment 3 Karsten Wade 2004-09-03 17:05:13 EDT
I've read over the outline at:

http://people.redhat.com/mjohnson/docs/fedora/docbook-emacs-quickstart/index.html

This looks really good.

Suggest a new small section 5.3 Using xmlto on the command line.

For 2. Setting up DocBook, suggest the following:

* Don't specify version of FC (just use &FC;).
* Point users at system-config-packages to add the
Authoring/Publishing Group; this lets the local distro and versions
take care of themselves.
* For 2.1 and 2.2, avoid package version numbers, use <replaceable/>
often :)

I really like the 1. Introduction and how it is ordered, including
have the Additional Resources up front.  Please include the text from
the message below about Googling for resources and IP issues, and
we'll make this intro <section> a standard template to use ... we
should in fact have this blurb as an entity that must be called from
within the Additional Resources <section>; it can be just a properly
formatted set of <para/> blocks.  &NONFC-RESOURCES; ?

http://www.redhat.com/archives/fedora-docs-list/2004-August/msg00139.html

Here is the text from that message:

## begin &NONFC-RESOURCES;

"One of the powers of Fedora is the enormous community behind it. 
You will find that community is your best resource for using Fedora.  To
find popular and useful websites with information, use your
favorite Web search engine, such as http://www.google.com.  Try search
terms such as:

  using fedora to <insert what you want to make Fedora do>  
  fedora multimedia software
  fedora packages

While you are encouraged to find new software that is compatible with
Fedora, downloading software from an unfamiliar website carries some
risks.  One reason some technologies are not included in Fedora is
because of concerns over known patents.  As you download, be
knowledgeable about intellectual property issues and don't hesitate to
ask questions of the host site making the download available."

## end &NONFC-RESOURCES;

Keep on going, enjoy your vacation. :)
Comment 4 eric@christensenplace.us 2009-08-05 14:25:26 EDT
Is this still in development or needed?
Comment 5 Paul W. Frields 2009-08-05 19:41:35 EDT
Wow, that bug's got whiskers.  Psgml doesn't even work on some new Emacs that I've tried.  I think this is a WONTFIX at this point.

Note You need to log in before you can comment on or make changes to this bug.