Bug 1300320 - rhnreg_ks warnings in F23
rhnreg_ks warnings in F23
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
2.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2016-01-20 08:19 EST by Lukáš Hellebrandt
Modified: 2017-09-28 14:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 03:58:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukáš Hellebrandt 2016-01-20 08:19:43 EST
Description of problem:
rhnreg_ks complains about not being able to enable yum-rhn-plugin + some GUdev warning , on Fedora 23

Version-Release number of selected component (if applicable):
Fedora 23
rhnreg_ks (Spacewalk Client Tools) 2.4.5-2

How reproducible:
On Fedora 23

Steps to Reproduce:
# rhnreg_ks --activationkey=<key> --force

Actual results:
/usr/share/rhn/up2date_client/hardware_gudev.py:16: PyGIWarning: GUdev was imported without specifying a version first. Use gi.require_version('GUdev', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GUdev
Warning: yum-rhn-plugin is not present, could not enable it.

Expected results:
Registering a system without complaining

Additional info:
Probably because Fedora 23 has dnf
Comment 1 Lukáš Hellebrandt 2016-01-20 08:23:04 EST
Possibly related to #1259426
Comment 2 Jan Dobes 2016-01-20 09:16:30 EST
We have pull request fixing it:

https://github.com/spacewalkproject/spacewalk/pull/337
Comment 3 Tomáš Kašpárek 2016-01-20 09:28:30 EST
should be fixed by spacewalk.git(master): 361efdfda34b381157b11bde1e7fcd06c64347c9
Comment 4 Tomáš Kašpárek 2016-06-16 03:58:32 EDT
Spacewalk 2.5 was released.
Comment 5 Eric Herget 2017-09-28 14:09:53 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.