Bug 1300340 - Yum fails to unpack rhevm-reports-setup package when upgrading
Yum fails to unpack rhevm-reports-setup package when upgrading
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-reports
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Anton Marchukov
Petr Matyáš
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 08:58 EST by Petr Matyáš
Modified: 2016-02-18 06:13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:13:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: External
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑3.6.z?
pmatyas: planning_ack?
sbonazzo: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Petr Matyáš 2016-01-20 08:58:39 EST
Description of problem:
After upgrading from 3.6.2-9 yum upgrade fails with:
Error unpacking rpm package rhevm-reports-setup-3.6.2.4-1.el6ev.noarch
error: unpacking of archive failed: cpio: read
rhevm-reports-setup-3.6.2.3-2.el6ev.noarch was supposed to be removed but is not!

Version-Release number of selected component (if applicable):
3.6.2-10

How reproducible:
always

Steps to Reproduce:
1. yum install rhevm-reports-setup for 3.6.2-9
2. yum update to 3.6.2-10
3.

Actual results:
fails when unpacking

Expected results:
correct installation

Additional info:
Comment 1 Anton Marchukov 2016-01-20 11:04:05 EST
This is a result of eng-ops problem https://engineering.redhat.com/rt/Ticket/Display.html?id=384646 some packages were downloaded broken from brew.

I have manually verified rpms on 3.6.2-10 using rpm -K and replaced broken packages. Now all checksums are ok.
Comment 2 Red Hat Bugzilla Rules Engine 2016-01-20 11:04:08 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 3 Red Hat Bugzilla Rules Engine 2016-01-20 11:04:08 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 4 Red Hat Bugzilla Rules Engine 2016-01-20 11:04:08 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Red Hat Bugzilla Rules Engine 2016-01-20 16:17:34 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.