Bug 1300354 - blktrace manpage still contains undocumented internal option -k
blktrace manpage still contains undocumented internal option -k
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: blktrace (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Eric Sandeen
Karel Srot
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 09:31 EST by Jaroslav Aster
Modified: 2016-11-04 03:41 EDT (History)
0 users

See Also:
Fixed In Version: blktrace-1.0.5-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300353
Environment:
Last Closed: 2016-11-04 03:41:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Aster 2016-01-20 09:31:38 EST
The same issue on rhel-7.

# rpm -q blktrace
blktrace-1.0.5-6.el7.x86_64

# man blktrace | col -b | grep -- '-k'
       blktrace -d dev [ -r debugfs_path ] [ -o output ] [-k ] [ -w time ] [ -a action ] [ -A action_mask ] [ -v ]


+++ This bug was initially created as a clone of Bug #1300353 +++

Description of problem:

blktrace manpage still contains undocumented internal option -k. Option -k/--kill was removed in version 1.0.1-4 as undocumented internal option, but the removal was not complete properly. See https://bugzilla.redhat.com/show_bug.cgi?id=583624#c26.

Version-Release number of selected component (if applicable):

blktrace-1.0.1-7.el6

How reproducible:

100%

Steps to Reproduce:

# man blktrace | col -b | grep -- '-k'
       blktrace  -d  dev [ -r debugfs_path ] [ -o output ] [-k ] [ -w time ] [

Actual results:

There is -k option in blktrace manpage.

Expected results:

There is no -k option in blktrace manpage.
Comment 5 errata-xmlrpc 2016-11-04 03:41:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2499.html

Note You need to log in before you can comment on or make changes to this bug.