Bug 1300389 - Backport related patches for qemu-rhev (qemu-2.5 based)
Backport related patches for qemu-rhev (qemu-2.5 based)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.3
aarch64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Wei Huang
Virtualization Bugs
:
Depends On:
Blocks: 1173755
  Show dependency treegraph
 
Reported: 2016-01-20 11:06 EST by Wei Huang
Modified: 2016-04-26 10:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-26 10:23:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Huang 2016-01-20 11:06:20 EST
This BZ is a place-holder to book-keep the patches required for qemu-rhev 2.5. This is important because we strive to have a full-fledged 2.5 qemu for various reasons (integration, QE testing). Note that we will have a 2.6 rebased QEMU in the future. So some patches listed here will be dropped.
Comment 2 Wei Huang 2016-01-20 15:20:26 EST
The following is the list of backport I have so far. They are classified based on the functionality:

[MISC]
fb91058 - Shannon Zhao: ARM: virt: Don't generate RTC ACPI device when using UEF

[GPIO-POWERDOWN]
18ecf94 - Wei Huang: AArch64: add ARM PL061 into default configure list
842b62b - Shannon Zhao: ARM: Virt: Add gpio-keys node for Poweroff using DT
9ea1717 - Shannon Zhao: ARM: Virt: Add QEMU powerdown notifier and hook it to GP
1ad32f3 - Shannon Zhao: ARM: ACPI: Add _E03 for Power Button
4ed206e - Shannon Zhao: ACPI: Add aml_gpio_int() wrapper for GPIO Interrupt Conn
049f306 - Shannon Zhao: ACPI: Add GPIO Connection Descriptor
dbaa8b3 - Shannon Zhao: ARM: ACPI: Add power button device in ACPI DSDT table
93a428a - Shannon Zhao: ARM: ACPI: Add GPIO controller in ACPI DSDT table
903c557 - Shannon Zhao: ARM: Virt: Add a GPIO controller
Comment 3 Andrew Jones 2016-04-26 10:23:08 EDT
Closing as current-release, since we'll get all 2.5 and even 2.6 patches through rebases.

Note You need to log in before you can comment on or make changes to this bug.