This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1300390 - spontaneous sigbus in applications under wayland
spontaneous sigbus in applications under wayland
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pixman (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 11:09 EST by Matthias Clasen
Modified: 2016-01-25 14:44 EST (History)
3 users (show)

See Also:
Fixed In Version: gtk3-3.19.7-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 14:44:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
polari stacktrace (6.70 KB, text/plain)
2016-01-20 11:09 EST, Matthias Clasen
no flags Details
gnome-terminal stacktrace (4.57 KB, text/plain)
2016-01-20 11:10 EST, Matthias Clasen
no flags Details

  None (edit)
Description Matthias Clasen 2016-01-20 11:09:32 EST
Created attachment 1116685 [details]
polari stacktrace

I've been seeing this problem on my system since before Xmas. When running a Wayland session, apps will spontaneously crash with a sigbus. Most frequently, it hits gnome-terminal and polari, but that may just be because I spend most of my time there.
Comment 1 Matthias Clasen 2016-01-20 11:10 EST
Created attachment 1116686 [details]
gnome-terminal stacktrace
Comment 2 Matthias Clasen 2016-01-20 11:22:32 EST
$ lspci -n -s 0:2
00:02.0 0300: 8086:0166 (rev 09)

$ rpm -q pixman
pixman-0.33.6-1.fc24.x86_64
Comment 3 Ray Strode [halfline] 2016-01-25 14:44:42 EST
should be fixed in tomorrow's rawhide. please lemme know if not

Note You need to log in before you can comment on or make changes to this bug.