Bug 1300402 - tempest requests newer python-fixtures
tempest requests newer python-fixtures
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: David Kranz
tkammer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 11:57 EST by Attila Fazekas
Modified: 2016-04-07 17:25 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-tempest-liberty-20160126.2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:25:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Fazekas 2016-01-20 11:57:34 EST
Description of problem:
'tempest help' throws an error message.

Version-Release number of selected component (if applicable):
openstack-tempest-liberty-20151020.2.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
tempest help

Actual results:
usage: tempest [--version] [-v] [--log-file LOG_FILE] [-q] [-h] [--debug]

Tempest cli application

optional arguments:
  --version            show program's version number and exit
  -v, --verbose        Increase verbosity of output. Can be repeated.
  --log-file LOG_FILE  Specify a file to log output. Disabled by default.
  -q, --quiet          Suppress output except warnings and errors.
  -h, --help           Show this help message and exit.
  --debug              Show tracebacks on errors.

Commands:
  complete       print bash completion command
  help           print detailed help for another command
Could not load EntryPoint.parse('init = tempest.cmd.init:TempestInit')
'ArgumentParser' object has no attribute 'debug'


Expected results:
usage: tempest [--version] [-v] [--log-file LOG_FILE] [-q] [-h] [--debug]

Tempest cli application

optional arguments:
  --version            show program's version number and exit
  -v, --verbose        Increase verbosity of output. Can be repeated.
  --log-file LOG_FILE  Specify a file to log output. Disabled by default.
  -q, --quiet          Suppress output except warnings and errors.
  -h, --help           Show this help message and exit.
  --debug              Show tracebacks on errors.

Commands:
  complete       print bash completion command
  help           print detailed help for another command
  init           Setup a local working environment for running tempest


Additional info:
After patching cliff a little it tells what it is the issue.

diff  -u /usr/lib/python2.7/site-packages/cliff/help.py.orig /usr/lib/python2.7/site-packages/cliff/help.py
--- /usr/lib/python2.7/site-packages/cliff/help.py.orig	2016-01-20 11:47:07.633327573 -0500
+++ /usr/lib/python2.7/site-packages/cliff/help.py	2016-01-20 11:47:51.293692900 -0500
@@ -22,8 +22,7 @@
                 factory = ep.load()
             except Exception as err:
                 app.stdout.write('Could not load %r\n' % ep)
-                if namespace.debug:
-                    traceback.print_exc(file=app.stdout)
+                traceback.print_exc(file=app.stdout)
                 continue
             try:
                 cmd = factory(app, None)

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/help.py", line 22, in __call__
    factory = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2259, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2272, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer)))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (fixtures 0.3.14 (/usr/lib/python2.7/site-packages), Requirement.parse('fixtures>=1.3.1'))


Tempest `compiled` to depend on fixtures>=1.3.1, and the installed one is older.

This changed the requirements.txt :
https://review.openstack.org/#/c/197285/

Adding newer fixtures package could help.
Comment 2 Steve Linabery 2016-03-17 14:48:53 EDT
Actually we decided to patch the downstream requirements.txt to reflect what was available in OSP8/liberty builds. openstack-tempest-liberty-20160126.2.el7ost contains that change and was smoketested to work with 'tempest --help'
Comment 5 errata-xmlrpc 2016-04-07 17:25:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.