Bug 1300417 - [RFE] OS::Neutron::ProviderNet resource does not support setting external router
[RFE] OS::Neutron::ProviderNet resource does not support setting external router
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
low Severity medium
: ga
: 9.0 (Mitaka)
Assigned To: Steve Baker
Amit Ugol
: FutureFeature, TestOnly, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 13:03 EST by John Browning
Modified: 2016-08-24 08:52 EDT (History)
15 users (show)

See Also:
Fixed In Version: openstack-heat-6.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
With this update, a new enhancement adds a new boolean property 'router_external' to the 'OS::Neutron::ProviderNet' resource. This option allows the template author to specify whether the network contains an external router.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 08:52:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 257074 None None None 2016-01-29 13:46 EST

  None (edit)
Description John Browning 2016-01-20 13:03:08 EST
Description of problem:
When working with Provider networks in OpenStack, most use cases require the setting --router:external during creation.
It appears the current resource OS::Neutron::ProviderNet does not support setting this option.


Version-Release number of selected component (if applicable):
7.2

How reproducible:
Always

Steps to Reproduce:
1.Create a heat template that creates a provider network.
2.Execute a neutron net-show <uuid of provider network>
3.View the output where External Router is false

Actual results:
Default external router setting is false

Expected results:
Have the ability to set this to true

Additional info:
Comment 1 Ryan Brown 2016-01-20 15:45:12 EST
Looked ahead to RHOS8 and upstream and neither support an external router parameter.
Comment 3 Zane Bitter 2016-02-17 16:30:06 EST
This is now merged upstream in Mitaka; it's the kind of new feature that we would not normally backport to Liberty (OSP8). Is there an urgent requirement for this, or should we retarget to OSP9?
Comment 10 Ola Pavlenko 2016-08-24 08:05:48 EDT
Verified

OSPD 9 latest bits
heat rpm 6.0.0-9
Comment 11 errata-xmlrpc 2016-08-24 08:52:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1761.html

Note You need to log in before you can comment on or make changes to this bug.